aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorxming <xmingske@gmail.com>2014-10-22 10:35:33 +0000
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-10-22 12:46:12 +0200
commit214e9e9be559b45ad31bae6799bfa9d2062e87c9 (patch)
treec4a311551347ad2617e3f77cdf3f7e9a9a747405
parentb1740f21e963eec94fe0d86f6a4a6e885e27d992 (diff)
downloadaports-214e9e9be559b45ad31bae6799bfa9d2062e87c9.tar.bz2
aports-214e9e9be559b45ad31bae6799bfa9d2062e87c9.tar.xz
testing/py-django-pipeline: new aport
an asset packaging library for Django https://github.com/cyberdelia/django-pipeline
-rw-r--r--testing/py-django-pipeline/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-django-pipeline/APKBUILD b/testing/py-django-pipeline/APKBUILD
new file mode 100644
index 0000000000..e05dc1b227
--- /dev/null
+++ b/testing/py-django-pipeline/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=django-pipeline
+pkgname=py-${_pkgname}
+pkgver=1.3.25
+pkgrel=0
+pkgdesc="an asset packaging library for Django"
+url="https://github.com/cyberdelia/django-pipeline"
+arch="noarch"
+license="BSD"
+#makedepends="python-dev py-setuptools py-django"
+makedepends="python-dev py-setuptools"
+depends="python"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cyberdelia/django-pipeline/archive/${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f2dea4e68d65ac5c399fe584366506d6 py-django-pipeline-1.3.25.tar.gz"
+sha256sums="92c4ba5543d3ad980cd3a65a121ced62a6ad6449a773269a693f54e0ca5c565f py-django-pipeline-1.3.25.tar.gz"
+sha512sums="2c66b8b60076a8d19049947a9465d96fd80098c6e560f6cb6ffa26fd17d267830d87913041f9876da1276b0224ef3e8b0183c56367741e11c0f010a236b87169 py-django-pipeline-1.3.25.tar.gz"