aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 12:26:34 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:59:38 -0300
commit23100d5a33a97a1efdbaa4a9ca1e1654b6022e7d (patch)
tree9b6b2d9ee459cc9305c6d403a66e906c6960510e
parent74e3b5d377e15dea49c94f5a13ee189497626f6d (diff)
downloadaports-23100d5a33a97a1efdbaa4a9ca1e1654b6022e7d.tar.bz2
aports-23100d5a33a97a1efdbaa4a9ca1e1654b6022e7d.tar.xz
community/libevhtp: modernize
-rw-r--r--community/libevhtp/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/libevhtp/APKBUILD b/community/libevhtp/APKBUILD
index 4f26a49c7b..4a0403a3c2 100644
--- a/community/libevhtp/APKBUILD
+++ b/community/libevhtp/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libevhtp
pkgver=1.2.18
-pkgrel=1
+pkgrel=2
pkgdesc="Flexible replacement for libevent's httpd API"
options="!check" # No testsuite
url="https://github.com/criticalstack/libevhtp/"
@@ -15,13 +15,14 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/criticalstack/libevhtp/archi
build() {
cmake \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=ON
make
}
package() {
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}
sha512sums="e01d771a9358fcf912578f34acd235711a3231029b453781f2992cf51cea26aa3f1eb170d3a834f15d4f9b3f37235fb006853eeee509945e2c18e3a7fbb06ae4 libevhtp-1.2.18.tar.gz"