aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-01-15 02:25:32 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2020-01-22 10:39:15 +0000
commit236e3cf9ef4e3275c73b4753ae1ec7b09b48b3b8 (patch)
tree91920baa02121107791a51478a6f4483984b872d
parent6b58221c699f5f6e5f264a692749611cd80a8a8f (diff)
downloadaports-236e3cf9ef4e3275c73b4753ae1ec7b09b48b3b8.tar.bz2
aports-236e3cf9ef4e3275c73b4753ae1ec7b09b48b3b8.tar.xz
community/certbot: upgrade to 1.1.0
-rw-r--r--community/certbot/APKBUILD10
-rw-r--r--community/certbot/cerbot_py3_looseversion.patch14
2 files changed, 11 insertions, 13 deletions
diff --git a/community/certbot/APKBUILD b/community/certbot/APKBUILD
index 4c8373b3e6..406ab8014b 100644
--- a/community/certbot/APKBUILD
+++ b/community/certbot/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot
-pkgver=1.0.0
+pkgver=1.1.0
pkgrel=0
pkgdesc="An ACME client that can update Apache/Nginx configurations"
url="https://github.com/certbot/certbot"
arch="noarch"
-license="Apache"
+license="Apache-2.0"
depends="
py3-acme
py3-configargparse
@@ -25,7 +25,7 @@ depends="
"
checkdepends="py3-augeas"
replaces="letsencrypt"
-source="https://pypi.io/packages/source/c/certbot/certbot-${pkgver}.tar.gz
+source="https://pypi.io/packages/source/c/certbot/certbot-$pkgver.tar.gz
cerbot_py3_looseversion.patch"
build() {
@@ -40,5 +40,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="ab432f3986b28d88857a550016b21240f5af85f145e12c291c9b99060c22d1d313b1ea0000db132ae0297f238096b7754ce37d409e5c83d8d67564058c657307 certbot-1.0.0.tar.gz
-e03356f528551a3b885c2eb45f18358bd1fd628b0b1a780f12cb49e6f9f3b9b81e2449d9bea4f48ba368d5c0c7f183e9d32d9a094a6d828339382f4b4938b30a cerbot_py3_looseversion.patch"
+sha512sums="b13a965bc89f8e5310d1580de8866935d53924a398b8f374c32feac761232c13c848b19d7a91e9a61cb56e9e0bf7ff79cc7468bb5fadbf3c9eef63b2ab501e04 certbot-1.1.0.tar.gz
+880c462d225567047e30c91e6f0cb57d8fff53785fb99430f1505051a6eb76252ee0aa82367d1e1ecc89030b06f82d2bac79a64f5f50f759db97d32d0e0f3fa0 cerbot_py3_looseversion.patch"
diff --git a/community/certbot/cerbot_py3_looseversion.patch b/community/certbot/cerbot_py3_looseversion.patch
index 399dc5da84..39a742970f 100644
--- a/community/certbot/cerbot_py3_looseversion.patch
+++ b/community/certbot/cerbot_py3_looseversion.patch
@@ -2,16 +2,14 @@ diff --git a/setup.py b/setup.py
index c1bf914..2f4c9d4 100644
--- a/setup.py
+++ b/setup.py
-@@ -3,7 +3,7 @@ import os
- import re
- import sys
-
+@@ -1,5 +1,5 @@
+ import codecs
-from distutils.version import StrictVersion
+from distutils.version import LooseVersion
- from setuptools import find_packages, setup, __version__ as setuptools_version
- from setuptools.command.test import test as TestCommand
-
-@@ -60,7 +60,7 @@ install_requires = [
+ import os
+ import re
+ import sys
+@@ -62,7 +62,7 @@
# So this dependency is not added for old Linux distributions with old setuptools,
# in order to allow these systems to build certbot from sources.
pywin32_req = 'pywin32>=227' # do not forget to edit pywin32 dependency accordingly in windows-installer/construct.py