aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-11 16:48:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 17:14:37 -0300
commit2799072d457987cb38349896d35fa8c6b7843851 (patch)
tree796eead28be53ba53e5f3dc4aa908ec50443098e
parent697e012ad59113649b7f6672b3410aca4d6075d1 (diff)
downloadaports-2799072d457987cb38349896d35fa8c6b7843851.tar.bz2
aports-2799072d457987cb38349896d35fa8c6b7843851.tar.xz
This Time
-rw-r--r--testing/i3lock-color/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/i3lock-color/APKBUILD b/testing/i3lock-color/APKBUILD
new file mode 100644
index 0000000000..7a7beb3620
--- /dev/null
+++ b/testing/i3lock-color/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=i3lock-color
+pkgver=2.12.c
+pkgrel=0
+pkgdesc="Fork of i3lock with extras features"
+url="https://github.com/PandorasFox/i3lock-color"
+arch="all"
+license="BSD-3-Clause"
+makedepends="libxcb-dev xcb-util-dev linux-pam-dev cairo-dev
+ xcb-util-image-dev fontconfig-dev libev-dev libxkbcommon-dev
+ libjpeg-turbo-dev xcb-util-xrm-dev
+ autoconf automake libtool"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PandorasFox/i3lock-color/archive/$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ autoreconf -fi
+ mkdir -p "$builddir"/build
+}
+
+build() {
+ cd build
+ ../configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-sanitizers
+ make
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir" install
+
+ # Rename to avoid conflict with i3lock
+ mv "$pkgdir"/usr/bin/i3lock "$pkgdir"/usr/bin/i3lock-color
+ mv "$pkgdir"/usr/share/man/man1/i3lock.1 "$pkgdir"/usr/share/man/man1/i3lock-color.1
+}
+
+sha512sums="2b8ce7b9e41694c6edb2394ba8a47bc05051500aa2ca6f46e082989c7bfed8540e343ffaa514c32b2e2b75f91b224c5b2d5958f1478a6d02ca87726ec876c90e i3lock-color-2.12.c.tar.gz"