aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-14 17:30:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-14 17:31:40 +0100
commit27e776d3dcba43e2c2123546e0fa5186136bb097 (patch)
tree031986cdc06a359668888586338c2f81f78df933
parent950ab7521313e266387ad8ff5708786ddc8a2530 (diff)
downloadaports-27e776d3dcba43e2c2123546e0fa5186136bb097.tar.bz2
aports-27e776d3dcba43e2c2123546e0fa5186136bb097.tar.xz
testing/dzonegit: new aport
-rw-r--r--testing/dzonegit/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/dzonegit/APKBUILD b/testing/dzonegit/APKBUILD
new file mode 100644
index 0000000000..c9789e2768
--- /dev/null
+++ b/testing/dzonegit/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=dzonegit
+pkgver=0.11
+pkgrel=0
+pkgdesc="Git hooks to manage a repository of DNS zones"
+url="https://github.com/oskar456/dzonegit"
+arch="noarch"
+license="MIT"
+depends="bind-tools git python3"
+checkdepends="py3-pytest py3-pytest-runner"
+source="https://github.com/oskar456/dzonegit/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a7841d66366882c1e85d7e9b2f1d33cb562baad0e8b988335116a8d86b60aff78362eb051f97bf4d38f9f93511a54f7ca1b9a1ed8b773798931e81cf54565d18 dzonegit-0.11.tar.gz"