aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Bashford <ianbashford@gmail.com>2019-12-21 22:07:27 +0000
committerRasmus Thomsen <oss@cogitri.dev>2019-12-22 23:57:15 +0100
commit299798d41e772f9f5b10ba5758315b65160836c1 (patch)
treea893acaf2a482964929119849dac5aa3ea62d05e
parent2e9920b3bdb6093e6f4a444b10cdea10ac4ee501 (diff)
downloadaports-299798d41e772f9f5b10ba5758315b65160836c1.tar.bz2
aports-299798d41e772f9f5b10ba5758315b65160836c1.tar.xz
community/dnscrypt-proxy: upgrade to 2.0.36
-rw-r--r--community/dnscrypt-proxy/APKBUILD6
-rw-r--r--community/dnscrypt-proxy/config-full-paths.patch28
2 files changed, 22 insertions, 12 deletions
diff --git a/community/dnscrypt-proxy/APKBUILD b/community/dnscrypt-proxy/APKBUILD
index 87ecb0ac2b..8139fd3b43 100644
--- a/community/dnscrypt-proxy/APKBUILD
+++ b/community/dnscrypt-proxy/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ian Bashford <ianbashford@gmail.com>
# Maintainer: Ian Bashford <ianbashford@gmail.com>
pkgname=dnscrypt-proxy
-pkgver=2.0.35
+pkgver=2.0.36
pkgrel=0
pkgdesc="A tool for securing communications between a client and a DNS resolver"
url="https://dnscrypt.info"
@@ -52,8 +52,8 @@ setup() {
install -m755 -D "$srcdir"/$pkgname.setup "$subpkgdir"/usr/sbin/setup-dnscrypt
}
-sha512sums="41e3c0646e215da3ce00e9ff9f22a4d3468b6589c424343ce0649c5a47cdbce26c2d9ffc3abf61c35d85eda964c499877d6f13619ce2308fe045a0272b1ca0e9 dnscrypt-proxy-2.0.35.tar.gz
+sha512sums="b1e3ed2a0226eaf35980b9f1125e0794640bcd837f99b8f2a0346498770305f04e27f13ccf97f01f0639285ef35f63cbbf72e9f2b419d592b615f6b07cdf7f2d dnscrypt-proxy-2.0.36.tar.gz
e0a72d39d47dc24b889d08beedbd9fdf21615f42fbab79980debdfd2c3feaa83dc3f776351f7dd13533cc85905ce4e01812e4ff8a80a9ccc0b21e9db7d6cb232 dnscrypt-proxy.initd
c001ae39da1b2db71764cab568f9ed18e4de0cea3d1a4e7bd6dd01a5668b81a888ea9eef99de6beac08857ad7f8eb1a32d730e946ac3563e4dcfa27147e35052 dnscrypt-proxy.confd
66dd43d84117a0151ae41f34d82b716760382a5a491424bf6418228ffd21f0dfbc88e34cc5074e11f97f006335d97b85367bb9ab1d96747a48e893c022ad52d0 dnscrypt-proxy.setup
-4c776751dca0a0c84fbf962e9c8292993c54d600b0ff5533d86088e34b6d12918568439d37059e8ad3ee3b7ad0181e8c26d86ca27d3fff12ef61f38ea4aa0faa config-full-paths.patch"
+b4dc13c948152dd411f3fc67a72ac5d1fbb835253ed6340beceb571e151323ca644c486107e6779fc32f4d3e958b333e7f1d45756257369ded95457918cbe8a1 config-full-paths.patch"
diff --git a/community/dnscrypt-proxy/config-full-paths.patch b/community/dnscrypt-proxy/config-full-paths.patch
index 017da3c555..1af5089c52 100644
--- a/community/dnscrypt-proxy/config-full-paths.patch
+++ b/community/dnscrypt-proxy/config-full-paths.patch
@@ -206,7 +206,7 @@ index 0000000..736ec29
+fallback_resolver = '9.9.9.9:53'
+
+
-+## Always use the fallback resolver before the system DNS settings
++## Always use the fallback resolver before the system DNS settings.
+
+ignore_system_dns = true
+
@@ -264,11 +264,15 @@ index 0000000..736ec29
+# Filters #
+#########################
+
++## Note: if you are using dnsmasq, disable the `dnssec` option in dnsmasq if you
++## configure dnscrypt-proxy to do any kind of filtering (including the filters
++## below and blacklists).
++## But you can still choose resolvers that do DNSSEC validation.
++
++
+## Immediately respond to IPv6-related queries with an empty response
+## This makes things faster when there is no IPv6 connectivity, but can
+## also cause reliability issues with some stub resolvers.
-+## Do not enable if you added a validating resolver such as dnsmasq in front
-+## of the proxy.
+
+block_ipv6 = false
+
@@ -278,6 +282,12 @@ index 0000000..736ec29
+block_unqualified = true
+
+
++## Immediately respond to queries for local zones instead of leaking them to
++## upstream resolvers (always causing errors or timeouts).
++
++block_undelegated = true
++
++
+## TTL for synthetic responses sent when a request has been blocked (due to
+## IPv6 or blacklists).
+
@@ -390,7 +400,7 @@ index 0000000..736ec29
+
+[query_log]
+
-+ ## Path to the query log file (absolute, or relative to the same directory as the executable file)
++ ## Path to the query log file (absolute, or relative to the same directory as the config file)
+ ## Can be /dev/stdout to log to the standard output (and set log_files_max_size to 0)
+
+ # file = '/var/log/dnscrypt-proxy/query.log'
@@ -417,7 +427,7 @@ index 0000000..736ec29
+
+[nx_log]
+
-+ ## Path to the query log file (absolute, or relative to the same directory as the executable file)
++ ## Path to the query log file (absolute, or relative to the same directory as the config file)
+
+ # file = '/var/log/dnscrypt-proxy/nx.log'
+
@@ -447,7 +457,7 @@ index 0000000..736ec29
+
+[blacklist]
+
-+ ## Path to the file of blocking rules (absolute, or relative to the same directory as the executable file)
++ ## Path to the file of blocking rules (absolute, or relative to the same directory as the config file)
+
+ # blacklist_file = '/etc/dnscrypt-proxy/blacklist.txt'
+
@@ -475,7 +485,7 @@ index 0000000..736ec29
+
+[ip_blacklist]
+
-+ ## Path to the file of blocking rules (absolute, or relative to the same directory as the executable file)
++ ## Path to the file of blocking rules (absolute, or relative to the same directory as the config file)
+
+ # blacklist_file = '/etc/dnscrypt-proxy/ip-blacklist.txt'
+
@@ -503,7 +513,7 @@ index 0000000..736ec29
+
+[whitelist]
+
-+ ## Path to the file of whitelisting rules (absolute, or relative to the same directory as the executable file)
++ ## Path to the file of whitelisting rules (absolute, or relative to the same directory as the config file)
+
+ # whitelist_file = '/etc/dnscrypt-proxy/whitelist.txt'
+
@@ -643,7 +653,7 @@ index 0000000..736ec29
+## A relay can be specified as a DNS Stamp (either a relay stamp, or a
+## DNSCrypt stamp), an IP:port, a hostname:port, or a server name.
+##
-+## The following example routes "example-server-1" via `anon-example-1` or `anon-example-2``,
++## The following example routes "example-server-1" via `anon-example-1` or `anon-example-2`,
+## and "example-server-2" via the relay whose relay DNS stamp
+## is "sdns://gRIxMzcuNzQuMjIzLjIzNDo0NDM".
+##