aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-05-12 08:25:42 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-05-12 08:25:42 +0000
commit29cb661e293e55f1d6b3c4ebb86064592e2e73b2 (patch)
tree670e8a2469d9658faaabafcf21cd23463d62799d
parent03c48cd02095c9eaa1703e6fb1323ff40429a722 (diff)
downloadaports-29cb661e293e55f1d6b3c4ebb86064592e2e73b2.tar.bz2
aports-29cb661e293e55f1d6b3c4ebb86064592e2e73b2.tar.xz
testing/yara: removed test-rules since they fail on ppc64 and aarch64
-rw-r--r--testing/yara/APKBUILD6
-rw-r--r--testing/yara/remove-test-rules.patch21
2 files changed, 25 insertions, 2 deletions
diff --git a/testing/yara/APKBUILD b/testing/yara/APKBUILD
index af1ac7b590..5d41ebc822 100644
--- a/testing/yara/APKBUILD
+++ b/testing/yara/APKBUILD
@@ -7,7 +7,8 @@ url="https://virustotal.github.io/yara/"
arch="all !armhf !armv7" # armhf: tests fail
license="BSD-3-Clause"
makedepends="automake file-dev openssl-dev autoconf libtool flex"
-source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/yara/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/yara/archive/v$pkgver.tar.gz
+remove-test-rules.patch"
subpackages="$pkgname-doc"
prepare() {
@@ -34,4 +35,5 @@ package() {
cp -r docs "$pkgdir/usr/share/doc/$pkgname"
}
-sha512sums="b78dac06d6f8b4153f3939fd3a5f6d50544c078520c240baa4bae00c552bf98d374c60629b256a75fe8943ef44830d5313e43f88cfb07ab561d22148f56b6fb7 yara-4.0.0.tar.gz"
+sha512sums="b78dac06d6f8b4153f3939fd3a5f6d50544c078520c240baa4bae00c552bf98d374c60629b256a75fe8943ef44830d5313e43f88cfb07ab561d22148f56b6fb7 yara-4.0.0.tar.gz
+dd3de272614fdfe2ee4658eacacdc54213af44879c1756f2432294221f5fba23e8de028da43f1d47e69c9209266f7d49a6619d7e1af9ef71bc14d07549ad3df1 remove-test-rules.patch"
diff --git a/testing/yara/remove-test-rules.patch b/testing/yara/remove-test-rules.patch
new file mode 100644
index 0000000000..6d8444f451
--- /dev/null
+++ b/testing/yara/remove-test-rules.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile.am b/Makefile.am
+index 062b77f..5bde105 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -33,8 +33,6 @@ test_arena_SOURCES = tests/test-arena.c
+ test_arena_LDADD = libyara/.libs/libyara.a
+ test_atoms_SOURCES = tests/test-atoms.c tests/util.c libyara/atoms.c
+ test_atoms_LDADD = libyara/.libs/libyara.a
+-test_rules_SOURCES = tests/test-rules.c tests/util.c
+-test_rules_LDADD = libyara/.libs/libyara.a
+ test_pe_SOURCES = tests/test-pe.c tests/util.c
+ test_pe_LDADD = libyara/.libs/libyara.a
+ test_elf_SOURCES = tests/test-elf.c tests/util.c
+@@ -59,7 +57,6 @@ check_PROGRAMS = \
+ test-alignment \
+ test-atoms \
+ test-api \
+- test-rules \
+ test-pe \
+ test-elf \
+ test-version \