aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-13 13:07:33 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-13 13:07:33 -0300
commit2c8d79850a80b5602811dff6c00aa79d371ff35a (patch)
tree5884db1360332db6d4a85b948b180a636d41f378
parent04005015fe7ad9c561fd73204d66e147d5acd9bd (diff)
downloadaports-2c8d79850a80b5602811dff6c00aa79d371ff35a.tar.bz2
aports-2c8d79850a80b5602811dff6c00aa79d371ff35a.tar.xz
testing/veracrypt: fix build
-rw-r--r--testing/veracrypt/APKBUILD7
-rw-r--r--testing/veracrypt/sysmacros.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/testing/veracrypt/APKBUILD b/testing/veracrypt/APKBUILD
index b53ee0a899..f1f4d19eeb 100644
--- a/testing/veracrypt/APKBUILD
+++ b/testing/veracrypt/APKBUILD
@@ -12,7 +12,9 @@ depends="device-mapper"
makedepends="fuse-dev wxgtk-dev libsm-dev yasm"
options="!check" # no test suite provided
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.bz2::https://launchpad.net/veracrypt/trunk/$pkgver/+download/${_pkgname}_${pkgver}_Source.tar.bz2"
+source="$pkgname-$pkgver.tar.bz2::https://launchpad.net/veracrypt/trunk/$pkgver/+download/${_pkgname}_${pkgver}_Source.tar.bz2
+ sysmacros.patch
+ "
builddir="$srcdir/"
build() {
@@ -42,4 +44,5 @@ package() {
EOF
}
-sha512sums="08795a42ab4eddb4792538d0207e6a45efad967abe257ba0a722b15f5bd43736f5e7cdce80b6c641dc1587c75f8f2b9b314f67e787a5a99031b5b47eea159b3d veracrypt-1.22.tar.bz2"
+sha512sums="08795a42ab4eddb4792538d0207e6a45efad967abe257ba0a722b15f5bd43736f5e7cdce80b6c641dc1587c75f8f2b9b314f67e787a5a99031b5b47eea159b3d veracrypt-1.22.tar.bz2
+34cbd10e3de5c0248a4d634e42a592b71c7c83e3edd4dd2ae05cc29bc7f9b3f71f85d32bbc5dcd68df9478a3fa2a0357ffbc9262baf76bf767c83b517ae29a09 sysmacros.patch"
diff --git a/testing/veracrypt/sysmacros.patch b/testing/veracrypt/sysmacros.patch
new file mode 100644
index 0000000000..84d89694e5
--- /dev/null
+++ b/testing/veracrypt/sysmacros.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Platform/Unix/FilesystemPath.cpp b/src/Platform/Unix/FilesystemPath.cpp
+index d6c9cd2..7c28af4 100644
+--- a/src/Platform/Unix/FilesystemPath.cpp
++++ b/src/Platform/Unix/FilesystemPath.cpp
+@@ -15,6 +15,7 @@
+ #include "Platform/StringConverter.h"
+ #include <stdio.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+
+ namespace VeraCrypt
+ {
+