aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinecrell <minecrell@minecrell.net>2020-03-27 13:05:34 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2020-03-30 12:24:32 +0000
commit2d66b57037c2555c2a67b4e48cb6489f8cfc4cb9 (patch)
treee8c493f6f850e40880280b99b81e6bbb4ca61a25
parent6ec1f82b556388269eabd7845e88e10a7b2f3e11 (diff)
downloadaports-2d66b57037c2555c2a67b4e48cb6489f8cfc4cb9.tar.bz2
aports-2d66b57037c2555c2a67b4e48cb6489f8cfc4cb9.tar.xz
community/bcc: remove unneeded stddef patch, enable on arm*
This was only needed because the swab.h header is broken in linux-headers. Also enable on arm* since it seems to build fine (on CI at least).
-rw-r--r--community/bcc/10-include-stddef.patch60
-rw-r--r--community/bcc/APKBUILD10
2 files changed, 4 insertions, 66 deletions
diff --git a/community/bcc/10-include-stddef.patch b/community/bcc/10-include-stddef.patch
deleted file mode 100644
index c48de72855..0000000000
--- a/community/bcc/10-include-stddef.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff --git a/src/cc/libbpf.c b/src/cc/libbpf.c
-index 974dc272..c74d9472 100644
---- a/src/cc/libbpf.c
-+++ b/src/cc/libbpf.c
-@@ -26,6 +26,7 @@
- #include <linux/bpf_common.h>
- #include <linux/if_packet.h>
- #include <linux/types.h>
-+#include <linux/stddef.h>
- #include <linux/perf_event.h>
- #include <linux/pkt_cls.h>
- #include <linux/rtnetlink.h>
-diff --git a/src/cc/libbpf/src/libbpf.c b/src/cc/libbpf/src/libbpf.c
-index 514b1a5..30c2d3e 100644
---- a/src/cc/libbpf/src/libbpf.c
-+++ b/src/cc/libbpf/src/libbpf.c
-@@ -26,6 +26,7 @@
- #include <errno.h>
- #include <asm/unistd.h>
- #include <linux/err.h>
-+#include <linux/stddef.h>
- #include <linux/kernel.h>
- #include <linux/bpf.h>
- #include <linux/btf.h>
-diff --git a/src/cc/perf_reader.c b/src/cc/perf_reader.c
-index dedb11d2..5d8a7e3a 100644
---- a/src/cc/perf_reader.c
-+++ b/src/cc/perf_reader.c
-@@ -26,6 +26,7 @@
- #include <sys/types.h>
- #include <unistd.h>
- #include <linux/types.h>
-+#include <linux/stddef.h>
- #include <linux/perf_event.h>
-
- #include "libbpf.h"
-diff --git a/src/cc/api/BPF.cc b/src/cc/api/BPF.cc
-index a3a14fee..1eff49ab 100644
---- a/src/cc/api/BPF.cc
-+++ b/src/cc/api/BPF.cc
-@@ -15,6 +15,7 @@
- */
-
- #include <linux/bpf.h>
-+#include <linux/stddef.h>
- #include <linux/perf_event.h>
- #include <unistd.h>
- #include <cstdio>
-diff --git a/src/cc/api/BPFTable.cc b/src/cc/api/BPFTable.cc
-index db62de74..0a2b4d04 100644
---- a/src/cc/api/BPFTable.cc
-+++ b/src/cc/api/BPFTable.cc
-@@ -16,6 +16,7 @@
-
- #include <fcntl.h>
- #include <linux/elf.h>
-+#include <linux/stddef.h>
- #include <linux/perf_event.h>
- #include <sys/epoll.h>
- #include <unistd.h>
diff --git a/community/bcc/APKBUILD b/community/bcc/APKBUILD
index e1a33004de..285fab637e 100644
--- a/community/bcc/APKBUILD
+++ b/community/bcc/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Adam Jensen <acjensen@gmail.com>
pkgname=bcc
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="A toolkit for creating efficient kernel tracing and manipulation programs"
url="https://github.com/iovisor/bcc/"
-arch="aarch64 x86 x86_64"
+arch="all !ppc64le !s390x" # build fails
license="Apache-2.0"
# bcc's test suite requires privileged access to run BPF programs
options="!check"
@@ -12,8 +12,7 @@ subpackages="$pkgname-static $pkgname-dev $pkgname-doc:_doc $pkgname-tools:_tool
_llvmver=10
makedepends="tar git llvm$_llvmver-dev llvm$_llvmver-static clang-dev clang-static cmake
python3 flex-dev bison luajit-dev build-base iperf linux-headers elfutils-dev zlib-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/iovisor/bcc/releases/download/v$pkgver/bcc-src-with-submodule.tar.gz
- 10-include-stddef.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/iovisor/bcc/releases/download/v$pkgver/bcc-src-with-submodule.tar.gz"
builddir="$srcdir/$pkgname"
prepare() {
@@ -71,5 +70,4 @@ _lua() {
mv "$pkgdir"/usr/bin/bcc-lua "$subpkgdir"/usr/bin
}
-sha512sums="9f95f70bbebb3b5e175b2c513a51c024fdbe67283c02b81b56cdef74b1720b82df40a4555c1e1fdcfa56c64cd418abfa11b371e4111ffb3997c848f014690471 bcc-0.13.0.tar.gz
-560b02ce2b2b14e56c63bfc92e0b77782e5f88769be3799cad838d0b8e5e4e8561aefdc3b81f1ac88c12f6fd1f82971482579d90903728ca2ff7e63d4c0217d2 10-include-stddef.patch"
+sha512sums="9f95f70bbebb3b5e175b2c513a51c024fdbe67283c02b81b56cdef74b1720b82df40a4555c1e1fdcfa56c64cd418abfa11b371e4111ffb3997c848f014690471 bcc-0.13.0.tar.gz"