aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-08-31 21:25:20 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2013-08-31 21:25:20 +0000
commit2d723b1c88d26b29096bc07f64a0cf4cf511b391 (patch)
treecc57e5842647c4a738aead3fd3a9960383c6007a
parent4364680bae06f106bb86312345f842dac1baf08e (diff)
downloadaports-2d723b1c88d26b29096bc07f64a0cf4cf511b391.tar.bz2
aports-2d723b1c88d26b29096bc07f64a0cf4cf511b391.tar.xz
testing/uwsgi: allow things using cffi to work
-rw-r--r--testing/uwsgi/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/uwsgi/APKBUILD b/testing/uwsgi/APKBUILD
index c724f1b38a..556a9b13d1 100644
--- a/testing/uwsgi/APKBUILD
+++ b/testing/uwsgi/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uwsgi
pkgver=1.4.8
-pkgrel=2
+pkgrel=3
pkgdesc="uWSGI application container server"
url=http://projects.unbit.it/uwsgi/
arch=all
license=GPL-2
-makedepends="linux-headers lua-dev python python-dev zeromq-dev"
+makedepends="linux-headers lua-dev python python-dev zeromq-dev paxctl"
subpackages="uwsgi-lua uwsgi-python:py"
source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
futimes.patch include-sched.patch lua-cache-update.patch
@@ -55,6 +55,9 @@ package() {
"$pkgdir"/etc/init.d/uwsgi || return 1
install -Dm644 "$srcdir"/uwsgi.confd \
"$pkgdir"/etc/conf.d/uwsgi || return 1
+
+ # disable emutramp/mprotect, this is needed for luajit and cffi
+ paxctl -czxm "$bindir"/uwsgi
}
lua() {