aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-03-25 15:22:10 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-03-26 15:43:20 +0300
commit2fe7e2a8bd5a437d62a1a3ec0725485e1656bd05 (patch)
treea71c3e57f3af5bf1c6c6010eb7104870aa57f817
parent403072ebeb13b08367b83a2555b7db773c95f183 (diff)
downloadaports-2fe7e2a8bd5a437d62a1a3ec0725485e1656bd05.tar.bz2
aports-2fe7e2a8bd5a437d62a1a3ec0725485e1656bd05.tar.xz
community/php7-imagick: fix dependencies
Fixes https://bugs.alpinelinux.org/issues/8263
-rw-r--r--community/php7-imagick/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/community/php7-imagick/APKBUILD b/community/php7-imagick/APKBUILD
index 3e2c52d7bb..0960356b66 100644
--- a/community/php7-imagick/APKBUILD
+++ b/community/php7-imagick/APKBUILD
@@ -3,14 +3,15 @@
pkgname=php7-imagick
_pkgreal=imagick
pkgver=3.4.3
-pkgrel=4
+pkgrel=5
_phpver=${pkgname#php}
_phpver=${_phpver%%-*}
pkgdesc="PHP$_phpver extension: Provides a wrapper to the ImageMagick library"
url="http://pecl.php.net/package/imagick"
arch="all"
license="PHP"
-depends="php$_phpver-common"
+depends="php$_phpver-common imagemagick"
+checkdepends="ghostscript-fonts"
makedepends="php$_phpver-dev autoconf libtool imagemagick-dev pcre-dev"
subpackages="$pkgname-dev"
source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
@@ -27,8 +28,11 @@ build() {
check() {
cd "$builddir"
- # XXX: Some test fails, ignore it for now.
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test || true
+ rm tests/150_Imagick_setregistry.phpt # no exception thrown
+ rm tests/229_Tutorial_fxAnalyzeImage_case1.phpt # time out
+ rm tests/236_Imagick_identify_basic.phpt # coredump https://bugs.php.net/bug.php?id=59444
+
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {