aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-21 17:09:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-21 17:11:37 +0100
commit30a07100692b2fa55235978e72f59b60d66f4478 (patch)
tree444e6b9e815b3519b5eac3f759adf37c31b4fded
parent7ebf92cda21a1f790f9a1614ebaadc7bccd7f17d (diff)
downloadaports-30a07100692b2fa55235978e72f59b60d66f4478.tar.bz2
aports-30a07100692b2fa55235978e72f59b60d66f4478.tar.xz
community/spice-gtk: fix build
- Add missing perl dependency, spice-gtk uses pod2man - Patch the version field, otherwise the git script runs and appends the -dirty suffix which is invalid in pkgconfig
-rw-r--r--community/spice-gtk/APKBUILD12
-rw-r--r--community/spice-gtk/fix-pkgconfig-version.patch13
2 files changed, 21 insertions, 4 deletions
diff --git a/community/spice-gtk/APKBUILD b/community/spice-gtk/APKBUILD
index 875f01afc7..22663e37e6 100644
--- a/community/spice-gtk/APKBUILD
+++ b/community/spice-gtk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-gtk
pkgver=0.37
-pkgrel=0
+pkgrel=1
pkgdesc="A GTK+ widget for SPICE clients"
url="http://spice-space.org/page/Spice-Gtk"
arch="all"
@@ -33,12 +33,15 @@ makedepends="
libva-dev
py3-six
py3-parsing
+ perl
"
options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
spice-glib:glib"
-source="https://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.bz2
- disable-test-relying-on-usb.patch"
+source="https://www.spice-space.org/download/gtk/spice-gtk-$pkgver.tar.bz2
+ disable-test-relying-on-usb.patch
+ fix-pkgconfig-version.patch
+ "
build() {
meson \
@@ -88,4 +91,5 @@ glib() {
}
sha512sums="a0a20bc6f25337d86e57fe1fc9586c4cc84457fc8c38cdcc5a728990a69018da0fca3ab5aa63349786b5a7508c82b716c94803eefb3495cffb7df4526db2d029 spice-gtk-0.37.tar.bz2
-fcb2eed3ccfdba422338aa292c56b61d5aa0b83e60feed8b042b44281d0090f7ec82a853332cf5d36338b5cc097031f5af25457866f11f2ed8a4c92f4372b863 disable-test-relying-on-usb.patch"
+fcb2eed3ccfdba422338aa292c56b61d5aa0b83e60feed8b042b44281d0090f7ec82a853332cf5d36338b5cc097031f5af25457866f11f2ed8a4c92f4372b863 disable-test-relying-on-usb.patch
+781ff842527cb23b894c45765035628406f487e4696900561de3d804704bb31f14ccbcd5f48303efcf43734e545643dbb011d3c9dbd46c1962a2307cef138350 fix-pkgconfig-version.patch"
diff --git a/community/spice-gtk/fix-pkgconfig-version.patch b/community/spice-gtk/fix-pkgconfig-version.patch
new file mode 100644
index 0000000000..bc96843f40
--- /dev/null
+++ b/community/spice-gtk/fix-pkgconfig-version.patch
@@ -0,0 +1,13 @@
+diff --git a/meson.build b/meson.build
+index 8c6288f..caef2d4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -2,7 +2,7 @@
+ # project definition
+ #
+ project('spice-gtk', 'c',
+- version : run_command('build-aux/git-version-gen', '@0@/.tarball-version'.format(meson.source_root()), check : true).stdout().strip(),
++ version : '0.37',
+ license : 'LGPLv2.1',
+ meson_version : '>= 0.49')
+