aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 18:13:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 19:56:00 -0300
commit31ffebddd3560c53683bbdb09dfd0e004966e0c0 (patch)
tree99134bf76a4814dd84cd080d9da2c4e5c4ee93fc
parent08d6d49a078e2a047cd8375aac0c85ce1392c7bc (diff)
downloadaports-31ffebddd3560c53683bbdb09dfd0e004966e0c0.tar.bz2
aports-31ffebddd3560c53683bbdb09dfd0e004966e0c0.tar.xz
community/botan: upgrade to 2.11.0
-rw-r--r--community/botan/APKBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/community/botan/APKBUILD b/community/botan/APKBUILD
index 3e89e56695..2abb39c03c 100644
--- a/community/botan/APKBUILD
+++ b/community/botan/APKBUILD
@@ -2,19 +2,17 @@
# Maintainer: tcely <botan+aports@tcely.33mail.com>
pkgname=botan
_pkgname=Botan
-pkgver=2.9.0
-pkgrel=1
+pkgver=2.11.0
+pkgrel=0
pkgdesc="Crypto and TLS for C++11"
url="https://botan.randombit.net/"
arch="all"
license="BSD-2-Clause"
-depends=""
depends_dev="boost-dev bzip2-dev openssl-dev sqlite-dev xz-dev zlib-dev"
makedepends="$depends_dev python2"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://botan.randombit.net/releases/$_pkgname-$pkgver.tgz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://botan.randombit.net/releases/$_pkgname-$pkgver.tar.xz"
builddir="$srcdir/$_pkgname-$pkgver"
-install=""
# secfixes:
# 2.9.0-r0:
@@ -27,8 +25,8 @@ install=""
# - CVE-2018-9127
build() {
- cd "$builddir"
-
+ # botan benefits from -O3. Upstream is using it when testing.
+ CXXFLAGS="$CXXFLAGS -O3" \
./configure.py \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -38,21 +36,20 @@ build() {
--with-openmp \
--with-openssl \
--with-sqlite3 \
- --with-zlib
+ --with-zlib \
+ --with-os-feature=getrandom \
+ --disable-static
make
}
check() {
- cd "$builddir"
./botan-test
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/lib/python*
}
-sha512sums="b88f3894a4a5b7b2fbff9be6eb0b774bf679a014bd2364811b7e63d4f323e22ca9ef916491afbc2cdf9db68727c1449fbeb6fd417e591560add0955517db3f65 Botan-2.9.0.tgz"
+sha512sums="a697a7f29788afc561cde35431e65e2f37e40fd45af89a6d060bf9988d28089905c6a1c005f9b23fb377547cd7a96a41f62c8d2f61a7f80d1ca1b9ccf857a2ce Botan-2.11.0.tar.xz"