aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-09-16 20:07:02 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-09-16 20:08:49 +0200
commit34867060e84abe7ec31ad8f7ac40e109220ca743 (patch)
tree486822a5974e2b19260595dee3bbd50297789927
parent43f2f98536d47f4fb17bebadbb547baccf156ab0 (diff)
downloadaports-34867060e84abe7ec31ad8f7ac40e109220ca743.tar.bz2
aports-34867060e84abe7ec31ad8f7ac40e109220ca743.tar.xz
testing/pcc: new aport
-rw-r--r--testing/pcc/APKBUILD58
-rw-r--r--testing/pcc/musl-fixes.patch20
2 files changed, 78 insertions, 0 deletions
diff --git a/testing/pcc/APKBUILD b/testing/pcc/APKBUILD
new file mode 100644
index 0000000000..bb8c79873b
--- /dev/null
+++ b/testing/pcc/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=pcc
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="The portable C compiler."
+url="http://pcc.ludd.ltu.se/"
+arch="x86 x86_64"
+license="BSD"
+depends="pcc-libs-dev bison"
+depends_dev=""
+makedepends="bison flex"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://pcc.ludd.ltu.se/pub/$pkgname-releases/$pkgname-$pkgver.tgz
+ musl-fixes.patch"
+
+builddir="$srcdir/"$pkgname-$pkgver
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ update_config_sub || return 1
+
+ sed -i -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' \
+ configure.ac || return 1
+ sed -i -e 's/AC_SUBST(strip)//' \
+ configure.ac || return 1
+}
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-stripping \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ # Don't conflict with gcc-doc.
+ mv "$pkgdir"/usr/share/man/man1/cpp.1 \
+ "$pkgdir"/usr/share/man/man1/$pkgname-cpp.1 || return 1
+}
+
+md5sums="1c0f22440753075d64f9f2c6ed0e8278 pcc-1.1.0.tgz
+7991640873523a3773721c9236728a2c musl-fixes.patch"
+sha256sums="d9e3fed84c767dcddefb6b1f854d5da8921f3f65d8bd02997743412f41474d64 pcc-1.1.0.tgz
+4d82536428dd42912ff9af025a95e405104b1c4491aab571189f66ab0dfa9104 musl-fixes.patch"
+sha512sums="5bd2b59fbb323016d215023ce77793ae66766e8e8192b44bf0707ee444658022e1645669c13eea8c81bc55c161eea3b0271d6b3098b8a7d51ce67eb86c7527b4 pcc-1.1.0.tgz
+0226a3f9d710840d7f710bc033d7eae6e5d5c8137eca6fe4147467066cb9fecf6acd03dc92f1559f4509eab84b5cc0e6c9533f2114903603644f728a411dc023 musl-fixes.patch"
diff --git a/testing/pcc/musl-fixes.patch b/testing/pcc/musl-fixes.patch
new file mode 100644
index 0000000000..cc58137c7f
--- /dev/null
+++ b/testing/pcc/musl-fixes.patch
@@ -0,0 +1,20 @@
+diff -upr pcc-1.1.0.orig/os/linux/ccconfig.h pcc-1.1.0/os/linux/ccconfig.h
+--- pcc-1.1.0.orig/os/linux/ccconfig.h 2016-09-16 20:00:46.350281549 +0200
++++ pcc-1.1.0/os/linux/ccconfig.h 2016-09-16 20:04:28.006146652 +0200
+@@ -39,14 +39,14 @@
+
+ #if defined(mach_i386)
+ #define CPPMDADD { "-D__i386__", NULL, }
+-#define DYNLINKER { "-dynamic-linker", "/lib/ld-linux.so.2", NULL }
++#define DYNLINKER { "-dynamic-linker", "/lib/ld-musl-i386.so.1", NULL }
+ #elif defined(mach_powerpc)
+ #define CPPMDADD { "-D__ppc__", NULL, }
+ #define DYNLINKER { "-dynamic-linker", "/lib/ld-linux.so.2", NULL }
+ #elif defined(mach_amd64)
+ #define CPPMDADD { "-D__x86_64__", "-D__x86_64", "-D__amd64__", \
+ "-D__amd64", "-D__LP64__", "-D_LP64", NULL, }
+-#define DYNLINKER { "-dynamic-linker", "/lib64/ld-linux-x86-64.so.2", NULL }
++#define DYNLINKER { "-dynamic-linker", "/lib/ld-musl-x86_64.so.1", NULL }
+ #ifndef MULTIARCH_PATH
+ #define DEFLIBDIRS { "/usr/lib64/", 0 }
+ #else