aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-01-31 00:01:42 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-06 09:09:40 +0000
commit35367aed0a3f7a78e51178198c15af5a7051d52e (patch)
tree0d14d37f039c5e9c062674a91f395029499f2b77
parent067448dfb7cb887e4d2efb9f31d16ed6cbc9e878 (diff)
downloadaports-35367aed0a3f7a78e51178198c15af5a7051d52e.tar.bz2
aports-35367aed0a3f7a78e51178198c15af5a7051d52e.tar.xz
community/virtualbox-guest-additions: upgrade to 6.0.4
-rw-r--r--community/virtualbox-guest-additions/APKBUILD6
-rw-r--r--community/virtualbox-guest-additions/uclibc-spawn.patch26
2 files changed, 3 insertions, 29 deletions
diff --git a/community/virtualbox-guest-additions/APKBUILD b/community/virtualbox-guest-additions/APKBUILD
index 6b01a6c5ba..69d9b402ef 100644
--- a/community/virtualbox-guest-additions/APKBUILD
+++ b/community/virtualbox-guest-additions/APKBUILD
@@ -2,12 +2,12 @@
# Contributor: Ben Allen <bensallen@me.com>
pkgname=virtualbox-guest-additions
-pkgver=6.0.0
+pkgver=6.0.4
pkgrel=0
pkgdesc="VirtualBox Addtions userland components"
arch='x86 x86_64'
-url='http://virtualbox.org'
+url='https://virtualbox.org/'
license="GPL custom"
install="$pkgname.pre-install"
makedepends="sed kbuild lvm2-dev yasm nasm zlib-dev openssl-dev curl-dev libxslt"
@@ -55,7 +55,7 @@ package() {
install -v -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-sha512sums="fbe193a3c4dfef943bd75e894452cc684e794e5fa2b25d0292f7fb3e84d5f1a890fe0a3a91dbae9a9b90ec87f12cb3d868457e1767a5841964568cf13a189561 VirtualBox-6.0.0.tar.bz2
+sha512sums="c2e5418bafd5d50b46e1bc70280753c2fdfbf7248d782fc398771839950fb575eaea437e9699d56f4d8c92ea4dc9ba8bed74379565dac6114f7e9c45aecc9fdb VirtualBox-6.0.4.tar.bz2
1da850bc30399ecde501eba5403ef1add1ae108d38394b01cd7f5cdf0462b855793d564d3adc1f770983b36529d77f3f7b0269fb65152468084a0a44c38e1638 futimens.patch
0169a620d62aa3de8124e0084f4b747b602fbdcab7892fe075606459e0200d412321c86da4c5d98309f4d7479ae1b5267ed28bea6c6e64fd8be88cab74f8e94c musl-fix-headers.patch
b1c47cb910ac751df7bd4bc10c5501e91d88a9b3e4fe181b02755d433df8e89a160a38422912266f0cc51ba0c09854dad513ba6f2634fc76c59cee7989b259eb musl-no-glibc.patch
diff --git a/community/virtualbox-guest-additions/uclibc-spawn.patch b/community/virtualbox-guest-additions/uclibc-spawn.patch
deleted file mode 100644
index 98b4e8ad6e..0000000000
--- a/community/virtualbox-guest-additions/uclibc-spawn.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./src/VBox/Runtime/r3/posix/process-creation-posix.cpp.orig
-+++ ./src/VBox/Runtime/r3/posix/process-creation-posix.cpp
-@@ -48,6 +48,9 @@
- * whether it is started detached or not. */
- # define HAVE_POSIX_SPAWN 1
- #endif
-+#if defined(__UCLIBC__)
-+#undef HAVE_POSIX_SPAWN
-+#endif
- #ifdef HAVE_POSIX_SPAWN
- # include <spawn.h>
- #endif
-@@ -103,11 +106,9 @@
- if (spwd)
- pw->pw_passwd = spwd->sp_pwdp;
-
-- /* be reentrant */
-- struct crypt_data *data = (struct crypt_data*)RTMemTmpAllocZ(sizeof(*data));
-- char *pszEncPasswd = crypt_r(pszPasswd, pw->pw_passwd, data);
-+ /* NOT reentrant */
-+ char *pszEncPasswd = crypt(pszPasswd, pw->pw_passwd);
- int fCorrect = !strcmp(pszEncPasswd, pw->pw_passwd);
-- RTMemTmpFree(data);
- if (!fCorrect)
- return VERR_PERMISSION_DENIED;
-