aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-27 09:20:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-27 09:40:00 +0000
commit36a0f13aa064d0534fee0e90c0ed85a5cae23bae (patch)
tree3f88a319ee26967d5a53e03df53ad093ab91f111
parentc882e5da284007861f4192f7a5c7dfc97c030448 (diff)
downloadaports-36a0f13aa064d0534fee0e90c0ed85a5cae23bae.tar.bz2
aports-36a0f13aa064d0534fee0e90c0ed85a5cae23bae.tar.xz
main/postfix: fixes for postmulti and permissions
move daemon_directory to /usr/libexec. Upstream recommends that shlib_directory should not be the same as shlib_directory. include *.proto files in /etc/postfix instead of doc dir. Those are needed by postmulti. fix permsions. The following dirs should be owned by root: /var/spool/postfix /var/spool/postfix/pid ref #9335
-rw-r--r--main/postfix/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index 295a8a67db..4029cf98d8 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
pkgver=3.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
arch="all"
@@ -50,7 +50,7 @@ prepare() {
build() {
cd $builddir
# needed for dynamic maps.
- local ccargs="-DHAS_SHL_LOAD -DDEF_DAEMON_DIR=\\\"/usr/lib/postfix\\\""
+ local ccargs="-DHAS_SHL_LOAD"
local auxlibs="$LDFLAGS"
# pcre
@@ -96,6 +96,10 @@ build() {
AUXLIBS_PGSQL="$(pkg-config --libs libpq)" \
AUXLIBS_SQLITE="$(pkg-config --libs sqlite3)" \
AUXLIBS_LMDB="$(pkg-config --libs lmdb)" \
+ config_directory=/etc/postfix \
+ meta_directory=/etc/postfix \
+ daemon_directory=/usr/libexec/postfix \
+ shlib_directory=/usr/lib/postfix \
dynamicmaps=yes \
shared=yes \
makefiles
@@ -119,8 +123,7 @@ package() {
make non-interactive-package \
install_root="$pkgdir" \
readme_directory=/usr/share/doc/$pkgname/readme \
- manpage_directory=/usr/share/man \
- shlib_directory=/usr/lib/postfix
+ manpage_directory=/usr/share/man
for i in postdrop postqueue; do
chgrp postdrop "$pkgdir"/usr/sbin/$i
@@ -129,14 +132,14 @@ package() {
mkdir -p "$pkgdir"/usr/share/doc/postfix/defaults/ \
"$pkgdir"/usr/share/licenses/${pkgname}/
- mv "$pkgdir"/etc/postfix/*.default "$pkgdir"/etc/postfix/*.proto \
+ mv "$pkgdir"/etc/postfix/*.default \
"$pkgdir"/usr/share/doc/postfix/defaults/
mv "$pkgdir"/etc/postfix/*LICENSE* \
"$pkgdir"/usr/share/licenses/${pkgname}/
- chown postfix:postfix "$pkgdir"/var/spool/postfix
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
chown postfix "$pkgdir"/var/spool/postfix/* "$pkgdir"/var/lib/postfix
+ chown root:postfix "$pkgdir"/var/spool/postfix/pid
chgrp postdrop "$pkgdir"/var/spool/postfix/maildrop \
"$pkgdir"/var/spool/postfix/public