aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-19 13:08:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-19 13:09:09 -0300
commit370d4f4199195d1435a1664a5153c96fd3e30303 (patch)
tree811ea87b6296619435b6875a57ba2dcfc4689d3e
parent886cd3a24dd1ff4797f900bb63934c1e39fd6f07 (diff)
downloadaports-370d4f4199195d1435a1664a5153c96fd3e30303.tar.bz2
aports-370d4f4199195d1435a1664a5153c96fd3e30303.tar.xz
community/evtest: fix build on ppc64le
-rw-r--r--community/evtest/APKBUILD7
-rw-r--r--community/evtest/fix-ppc64le-musl.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/community/evtest/APKBUILD b/community/evtest/APKBUILD
index 316fef0e06..5acade6a98 100644
--- a/community/evtest/APKBUILD
+++ b/community/evtest/APKBUILD
@@ -9,7 +9,9 @@ url="https://cgit.freedesktop.org/evtest/"
arch="all"
license="GPL-2.0"
makedepends="linux-headers autoconf automake libtool"
-source="https://src.fedoraproject.org/repo/pkgs/evtest/evtest-$pkgver.tar.bz2/sha512/94f9ff2642abbd0393d7583edd10f83487a1985963bf3186a0c957bf1d56cef30501bb38ac4df0312eab59f633a606e25638a09e43dc6f3bc31f49aa3c7cec52/evtest-$pkgver.tar.bz2"
+source="https://src.fedoraproject.org/repo/pkgs/evtest/evtest-$pkgver.tar.bz2/sha512/94f9ff2642abbd0393d7583edd10f83487a1985963bf3186a0c957bf1d56cef30501bb38ac4df0312eab59f633a606e25638a09e43dc6f3bc31f49aa3c7cec52/evtest-$pkgver.tar.bz2
+ fix-ppc64le-musl.patch
+ "
prepare() {
default_prepare
@@ -28,4 +30,5 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="94f9ff2642abbd0393d7583edd10f83487a1985963bf3186a0c957bf1d56cef30501bb38ac4df0312eab59f633a606e25638a09e43dc6f3bc31f49aa3c7cec52 evtest-1.34.tar.bz2"
+sha512sums="94f9ff2642abbd0393d7583edd10f83487a1985963bf3186a0c957bf1d56cef30501bb38ac4df0312eab59f633a606e25638a09e43dc6f3bc31f49aa3c7cec52 evtest-1.34.tar.bz2
+d436fc203af62d8463c60517dd9d75a866af62db5d074569621d421dd343d2acbf880735fec8cd3d3f2e8f3f97c25c2c8738d31448d78ffb275930ec299ba0a5 fix-ppc64le-musl.patch"
diff --git a/community/evtest/fix-ppc64le-musl.patch b/community/evtest/fix-ppc64le-musl.patch
new file mode 100644
index 0000000000..c551fa4484
--- /dev/null
+++ b/community/evtest/fix-ppc64le-musl.patch
@@ -0,0 +1,13 @@
+diff --git a/evtest.c b/evtest.c
+index 37d4f85..018d1ac 100644
+--- a/evtest.c
++++ b/evtest.c
+@@ -59,6 +59,7 @@
+ #include <sys/time.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <sys/limits.h> /* for PATH_MAX */
+
+ #define BITS_PER_LONG (sizeof(long) * 8)
+ #define NBITS(x) ((((x)-1)/BITS_PER_LONG)+1)
+