aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-01 19:59:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-01 20:04:47 -0300
commit37192b08909f25ba9cfffbf10f3848d9ce67ad99 (patch)
tree7df55246a9d688d4ed702e0579e53bf72e5e2c12
parentd79c3c4b07a824538c09125a3d722060bc2a7e64 (diff)
downloadaports-37192b08909f25ba9cfffbf10f3848d9ce67ad99.tar.bz2
aports-37192b08909f25ba9cfffbf10f3848d9ce67ad99.tar.xz
testing/py3-unpaddedbase64: new aport
https://github.com/matrix-org/python-unpaddedbase64 Base64 Encoding and Decoding without = padding
-rw-r--r--testing/py3-unpaddedbase64/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-unpaddedbase64/APKBUILD b/testing/py3-unpaddedbase64/APKBUILD
new file mode 100644
index 0000000000..667be5fea1
--- /dev/null
+++ b/testing/py3-unpaddedbase64/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-unpaddedbase64
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Base64 Encoding and Decoding without = padding"
+url="https://github.com/matrix-org/python-unpaddedbase64"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/matrix-org/python-unpaddedbase64/archive/v$pkgver.tar.gz"
+builddir="$srcdir/python-unpaddedbase64-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7e5954d8c4fbf55f21c8cda493e7db613feaa16224139ea550958073c182e4fba953c5f9670c72d1d0fc1402144a1dbeb9fa4df437a8ac51a29cce715e14f15d py3-unpaddedbase64-1.1.0.tar.gz"