aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-23 10:53:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-26 08:54:41 +0000
commit3a774619019cfe608f75a2cb301d0d14a814165d (patch)
treed300f5c887f86a87525f1dde2f5492172379939a
parent5ed3c4cc95d15f7e7e54a78e03712b24979d7d37 (diff)
downloadaports-3a774619019cfe608f75a2cb301d0d14a814165d.tar.bz2
aports-3a774619019cfe608f75a2cb301d0d14a814165d.tar.xz
main/nagios-plugins: rebuild against mariadb-connector-c
-rw-r--r--main/nagios-plugins/APKBUILD7
-rw-r--r--main/nagios-plugins/fix-mysql-headers.patch24
2 files changed, 29 insertions, 2 deletions
diff --git a/main/nagios-plugins/APKBUILD b/main/nagios-plugins/APKBUILD
index 55921faa36..b185444eb5 100644
--- a/main/nagios-plugins/APKBUILD
+++ b/main/nagios-plugins/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Jeff Bilyk <jbilyk@gmail.com>
pkgname=nagios-plugins
pkgver=2.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="Plugins for Nagios to check services on hosts"
url="https://nagios-plugins.org"
arch="all"
@@ -21,12 +21,14 @@ depends_snmp="net-snmp-tools"
makedepends="openssh-client bind-tools samba-client fping grep rpcbind
lm_sensors net-snmp-tools
file freeradius-client-dev libdbi-dev libpq linux-headers mariadb-dev
+ mariadb-connector-c-dev
net-snmp-dev openldap-dev opensmtpd libressl-dev postgresql-dev"
install="$pkgname.post-upgrade"
pkgusers="nagios"
pkggroups="nagios"
options="suid"
source="https://www.nagios-plugins.org/download/$pkgname-$pkgver.tar.gz
+ fix-mysql-headers.patch
check_openrc
nagios-openrc.sudoers"
builddir="$srcdir/$pkgname-$pkgver"
@@ -50,7 +52,7 @@ _plugins="$_plugins openrc tcp"
prepare() {
- cd "$builddir"
+ default_prepare
update_config_sub
}
@@ -151,5 +153,6 @@ _all() {
}
sha512sums="6ffe313a56a305b382f62abc0f0958d7078f9050e1340f30721d6e6f71944b57b1650e90e6835c35dd7c9f3f4b4cee9f235b8382b0811db30b3729daaafc9bc3 nagios-plugins-2.2.1.tar.gz
+5db87cf63fb6d1f72122bd7c72f012aab2724328d3d71da546970792a6cdeedbe008f3feef03f7432f100836ace3701c1902b820c93a79e5fa13abe8b337da0d fix-mysql-headers.patch
12d87542631494df1c961e547c19107a025829509e174e8208111736141c12e20dbf490c55d487af39d47cefca5507cd98c973b7b20ae3f961dcbfd167195d8e check_openrc
171c9ad14d1027541b78df76063e6d34483dd536219fb83e0346e191739529d59c8d6be468af7f1c4c93b20baf9a32879510f15ec3d06aa1eefaf5d785ea8546 nagios-openrc.sudoers"
diff --git a/main/nagios-plugins/fix-mysql-headers.patch b/main/nagios-plugins/fix-mysql-headers.patch
new file mode 100644
index 0000000000..34926a73fe
--- /dev/null
+++ b/main/nagios-plugins/fix-mysql-headers.patch
@@ -0,0 +1,24 @@
+diff -up ./plugins/check_mysql.c.fix_mysql_f27 ./plugins/check_mysql.c
+--- ./plugins/check_mysql.c.fix_mysql_f27 2017-11-20 21:19:47.597527944 -0500
++++ ./plugins/check_mysql.c 2017-11-20 21:17:15.715921194 -0500
+@@ -41,7 +41,7 @@ const char *email = "devel@nagios-plugin
+ #include "utils_base.h"
+ #include "netutils.h"
+
+-#include <mysql.h>
++#include <server/mysql.h>
+ #include <mysqld_error.h>
+ #include <errmsg.h>
+
+diff -up ./plugins/check_mysql_query.c.fix_mysql_f27 ./plugins/check_mysql_query.c
+--- ./plugins/check_mysql_query.c.fix_mysql_f27 2017-11-20 21:20:01.369764323 -0500
++++ ./plugins/check_mysql_query.c 2017-11-20 21:17:20.378001200 -0500
+@@ -38,7 +38,7 @@ const char *email = "devel@nagios-plugin
+ #include "utils_base.h"
+ #include "netutils.h"
+
+-#include <mysql.h>
++#include <server/mysql.h>
+ #include <errmsg.h>
+
+ char *db_user = NULL;