aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-09 19:51:40 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 16:20:58 -0300
commit3ab725f2f72f5d816c9592ca5f80462f48213906 (patch)
treebe110f022b20cde65785a138f6f3745cb190e0dc
parent48600bca7d6853357438b2fc0e954cae0858af2b (diff)
downloadaports-3ab725f2f72f5d816c9592ca5f80462f48213906.tar.bz2
aports-3ab725f2f72f5d816c9592ca5f80462f48213906.tar.xz
testing/openttd: upgrade to 1.9.3
-rw-r--r--testing/openttd/APKBUILD34
-rw-r--r--testing/openttd/fix-pthread-stacksize.patch6
2 files changed, 18 insertions, 22 deletions
diff --git a/testing/openttd/APKBUILD b/testing/openttd/APKBUILD
index 62d2da8462..c880e02a52 100644
--- a/testing/openttd/APKBUILD
+++ b/testing/openttd/APKBUILD
@@ -1,31 +1,29 @@
# Contributor: Adrian Siekierka <kontakt@asie.pl>
# Maintainer: Adrian Siekierka <kontakt@asie.pl>
pkgname=openttd
-pkgver=1.8.0
-pkgrel=1
+pkgver=1.9.3
+pkgrel=0
pkgdesc="Open source version of the Transport Tycoon Deluxe simulator"
-url="http://openttd.org"
+url="https://www.openttd.org"
arch="all"
-license="GPL-2.0-only"
-depends=""
-makedepends="fontconfig-dev freetype-dev libpng-dev lzo-dev sdl-dev xz-dev zlib-dev"
+license="GPL-2.0-or-later"
+makedepends="fontconfig-dev freetype-dev icu-dev libpng-dev lzo-dev sdl-dev xz-dev zlib-dev"
+checkdepends="openttd-opengfx"
subpackages="$pkgname-doc $pkgname-lang::noarch"
-source="https://binaries.openttd.org/releases/$pkgver/$pkgname-$pkgver-source.tar.xz
- fix-pthread-stacksize.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://cdn.openttd.org/openttd-releases/$pkgver/openttd-$pkgver-source.tar.xz
+ fix-pthread-stacksize.patch
+ "
build() {
- cd "$builddir"
-
# OpenTTD's builtin strip does not work when cross-compiling,
# but it will be done automatically later in the package build.
./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ --build="$CBUILD" \
+ --host="$CHOST" \
--disable-strip \
--prefix-dir=/usr \
--binary-dir=bin \
- --install-dir="${pkgdir}" \
+ --install-dir="$pkgdir" \
--with-sdl \
--with-zlib \
--with-liblzma \
@@ -37,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
- bin/openttd --version
+ make test
}
package() {
- cd "$builddir"
make install
}
@@ -58,5 +54,5 @@ lang() {
done
}
-sha512sums="a2d61b3c94a550c8f3a581127df8c3459b1ddff5ba924942c468cbc70e88e0bf4405cecb68a91243b544ead64f215aa8d489a07b38dce507ae7d59e8ec155d7a openttd-1.8.0-source.tar.xz
-90db187919cb802ea6abddc03f09e85fe278175f5830f26e86d4a3b98f60bf233b0acaafd7e7a8f01c8e9a6bc059c171c88f8fcf36fc713624f972a8a8ad073f fix-pthread-stacksize.patch"
+sha512sums="e2208f730cf26c2df9b1950e885e20471060217dd47f2483db3f1cc86b40658d71208f27caab38a9fa513cfddb33c791a0972336dfa902a6d110ef246d936a34 openttd-1.9.3-source.tar.xz
+b6dcf89c515b199c8e585ffcfab166346074e1e6df8976f0630ceaee1d5411f57c0319e6afd1bc8608aa21a8cddae9e758de8b8c3d582a2b26a9037e4b6a704a fix-pthread-stacksize.patch"
diff --git a/testing/openttd/fix-pthread-stacksize.patch b/testing/openttd/fix-pthread-stacksize.patch
index 51a3168ce1..a4b3155186 100644
--- a/testing/openttd/fix-pthread-stacksize.patch
+++ b/testing/openttd/fix-pthread-stacksize.patch
@@ -1,7 +1,7 @@
Only in openttd-1.8.0-mod: src/saveload/.saveload.cpp.swp
---- openttd-1.8.0/src/thread/thread_pthread.cpp
-+++ openttd-1.8.0-mod/src/thread/thread_pthread.cpp
-@@ -38,7 +38,10 @@
+--- a/src/thread/thread_pthread.cpp
++++ b/src/thread/thread_pthread.cpp
+@@ -42,7 +42,10 @@
self_destruct(self_destruct),
name(name)
{