aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-30 21:38:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-04 00:38:16 -0300
commit3b6dd956f61d2b9c8bd4b9e30af3498604a13346 (patch)
tree0053897f5a294fd030f9acba9fd5d1c486430c7d
parentc104c5d6b4b6851277fd6cd2623220b07f7b5dc4 (diff)
downloadaports-3b6dd956f61d2b9c8bd4b9e30af3498604a13346.tar.bz2
aports-3b6dd956f61d2b9c8bd4b9e30af3498604a13346.tar.xz
community/quazip: upgrade to 0.8.1
-rw-r--r--community/quazip/APKBUILD19
-rw-r--r--community/quazip/fix-cmake-path.patch (renamed from community/quazip/cmake-path.patch)7
2 files changed, 15 insertions, 11 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
index d3ccc10ec9..727ed5ea3e 100644
--- a/community/quazip/APKBUILD
+++ b/community/quazip/APKBUILD
@@ -2,24 +2,26 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quazip
-pkgver=0.7.6
-pkgrel=2
+pkgver=0.8.1
+pkgrel=0
pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
-options="!check" # Has no testsuite
+options="!check" # Testsuite only available with qmake not cmake
url="https://sourceforge.net/projects/quazip/"
arch="all"
# Has custom static linking exception
license="LGPL-2.1-or-later WITH custom-static-linking-exception"
makedepends="qt5-qtbase-dev cmake"
subpackages="$pkgname-dev $pkgname-doc"
-source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/$pkgver.tar.gz
- cmake-path.patch"
+source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/v$pkgver.tar.gz
+ fix-cmake-path.patch
+ "
replaces="quazip-qt5"
build() {
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_WITH_QT4:BOOL=OFF \
-DCMAKE_CXX_FLAGS="$CFLAGS -fPIC" \
..
@@ -29,7 +31,8 @@ build() {
package() {
make -C build DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ rm -f "$pkgdir"/usr/lib/*.a
}
-sha512sums="4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1 quazip-0.7.6.tar.gz
-06946c73c0e95e824066b55074086fd6aa0da2e9f4e0a267577276edf1048e8706a621c8e039a180512eaae00c88f32619ba59c7167c02d048374c1fef77b272 cmake-path.patch"
+sha512sums="d65dab16c2cbc4d8bb23dae5b2fdff5ef787aaff2653b8e75c3fc8ba1701f5568a52bdde39009f83c5069a9fe3331cd1a49cf965822c4180e88bbc341faa2bfb quazip-0.8.1.tar.gz
+430ac7af402812c7d070fae9e8faccc1779e6f95b595970f45cfda07031c2e6038828bcbed1eb11f450291c0d1c409eb852cf540d714db50110fbb84f6f06252 fix-cmake-path.patch"
diff --git a/community/quazip/cmake-path.patch b/community/quazip/fix-cmake-path.patch
index 79152dfa1e..946970fab3 100644
--- a/community/quazip/cmake-path.patch
+++ b/community/quazip/fix-cmake-path.patch
@@ -1,10 +1,11 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3d2fb55..98be14e 100644
+index 6fcdd95..71145fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,4 +60,4 @@ set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
add_subdirectory(quazip)
--install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_ROOT}/Modules)
-+install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/cmake/QuaZip)
+-install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION share/cmake/Modules)
++install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION lib/cmake/Modules)
+