aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-05 09:38:16 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-05 09:38:16 +0100
commit3e51570130f2587249436ae4ae20be5cda583d61 (patch)
treeca48911b83e7a23c174d8d9a468c275144f5b30b
parent7c78441134e54efbb34618f457d88c783c913361 (diff)
downloadaports-3e51570130f2587249436ae4ae20be5cda583d61.tar.bz2
aports-3e51570130f2587249436ae4ae20be5cda583d61.tar.xz
community/iprutils: fix license, remove systemd user services
-rw-r--r--community/iprutils/APKBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/community/iprutils/APKBUILD b/community/iprutils/APKBUILD
index ba3b4b3646..c6c9bdd325 100644
--- a/community/iprutils/APKBUILD
+++ b/community/iprutils/APKBUILD
@@ -1,23 +1,21 @@
# Maintainer: Breno Leitao <breno.leitao@gmail.com>
pkgname=iprutils
pkgver=2.4.16
-pkgrel=0
-pkgdesc="user space tools required by the ipr device driver."
+pkgrel=1
+pkgdesc="user space tools required by the ipr device driver"
url="https://github.com/bjking1/iprutils"
arch="ppc64le"
-license="CPL"
-depends="zlib ncurses"
+license="CPL-1.0"
makedepends="autoconf automake libtool linux-headers m4 ncurses-dev zlib-dev"
subpackages="$pkgname-doc"
_pkgver=${pkgver//./-}
-source="$pkgname-$pkgver.tar.gz::https://github.com/bjking1/$pkgname/archive/rel-$_pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bjking1/iprutils/archive/rel-$_pkgver.tar.gz"
builddir="$srcdir"/iprutils-rel-$_pkgver
prepare() {
default_prepare
- cd "$builddir"
- ./bootstrap.sh
+ ./bootstrap.sh
}
build() {
@@ -28,17 +26,16 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --without-systemd
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}