aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 09:39:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 09:39:57 -0300
commit3e9e8f24cea3a8dcdb2932e088bce55becba822e (patch)
tree897cde58fe63ef7273c8cb77f4983b2f053637c6
parentc46f5e02a5bf66a93ba99a63f33502def0ecdb58 (diff)
downloadaports-3e9e8f24cea3a8dcdb2932e088bce55becba822e.tar.bz2
aports-3e9e8f24cea3a8dcdb2932e088bce55becba822e.tar.xz
testing/py3-pygal: drop py2
-rw-r--r--testing/py3-pygal/APKBUILD36
1 files changed, 8 insertions, 28 deletions
diff --git a/testing/py3-pygal/APKBUILD b/testing/py3-pygal/APKBUILD
index ab0fb1b5b4..2c197393e3 100644
--- a/testing/py3-pygal/APKBUILD
+++ b/testing/py3-pygal/APKBUILD
@@ -1,47 +1,27 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=py-pygal
+pkgname=py3-pygal
_pkgname=pygal
pkgver=2.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="pygal is a dynamic SVG charting library written in python"
+options="!check" # Requires unpackaged dependencies
url="https://pygal.org"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="py-setuptools"
-makedepends="python2-dev python3-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
options="!check" # no test suite
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-pygal" # Backwards compatibility
+provides="py-pygal=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="5cb95ca5c0cf74ae476953f3503154a305a0b5e42c69191b0b46f6e6cfea8c806713fe175329a69b393654d055997b2063cf3b641e91009a2b7bef219bb49ddb pygal-2.4.0.tar.gz"