aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-08-31 10:35:06 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-08-31 10:35:06 +0000
commit3f3c3d2b3c001e4c85f2fa9ef71ee7932e39aceb (patch)
tree8afbb033ba5ee8006e1d598cdc89242791711750
parentdaecaf56104ec9c098015d7ecefb52ef8565f8f9 (diff)
downloadaports-3f3c3d2b3c001e4c85f2fa9ef71ee7932e39aceb.tar.bz2
aports-3f3c3d2b3c001e4c85f2fa9ef71ee7932e39aceb.tar.xz
main/llvm: fix previous change
-rw-r--r--main/llvm/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/main/llvm/APKBUILD b/main/llvm/APKBUILD
index ce33eba8ed..dcd9a2706a 100644
--- a/main/llvm/APKBUILD
+++ b/main/llvm/APKBUILD
@@ -227,10 +227,8 @@ build() {
# auto-detect it by guessing either.
ffi_include_dir="$(pkg-config --cflags-only-I libffi | sed 's|^-I||g')"
-
- mkdir -p "$_bootstrapdir" "$_builddir"
+ mkdir -p "$_bootstrapdir"
cd "$_bootstrapdir"
-
msg "Compiling bootstrap compiler"
cmake -G "Unix Makefiles" -Wno-dev ${_cmake_bootstrap_flags} \
-DCMAKE_C_FLAGS_RELEASE="${cflags}" \
@@ -253,8 +251,8 @@ build() {
CC="${_bootstrapdir}/bin/clang"
CXX="${_bootstrapdir}/bin/clang++"
- cd ../"$_builddir"
-
+ mkdir "$_builddir"
+ cd "$_builddir"
msg "Compiling final compiler"
cmake -G "Unix Makefiles" -Wno-dev ${_cmake_final_flags} \
-DCMAKE_C_COMPILER="${CC}" \