aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Bierwolf <a.b.bierwolf@gmail.com>2018-03-07 11:46:32 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-26 19:38:30 +0200
commit3fcd39c185482f6114e401eb3d8d8ea6f375873f (patch)
tree0413fdcf6c518369bef4a1384c8c5b851c53e331
parent3bfade0d1c6720cf49713fe30251f59509c005fe (diff)
downloadaports-3fcd39c185482f6114e401eb3d8d8ea6f375873f.tar.bz2
aports-3fcd39c185482f6114e401eb3d8d8ea6f375873f.tar.xz
testing/novnc: Upgraded to version 1.0.0
New version of novnc packaged.
-rw-r--r--testing/novnc/APKBUILD8
-rw-r--r--testing/novnc/alpine-specific-launch.js.patch25
2 files changed, 8 insertions, 25 deletions
diff --git a/testing/novnc/APKBUILD b/testing/novnc/APKBUILD
index 1ab4e7bdb5..4ccf7510bf 100644
--- a/testing/novnc/APKBUILD
+++ b/testing/novnc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Andre Bierwolf <a.b.bierwolf@gmail.com>
pkgname=novnc
_pkgname=noVNC
-pkgver=0.6.2
+pkgver=1.0.0
pkgrel=0
pkgdesc="VNC client using HTML5 (WebSockets, Canvas) with encryption (wss://) support"
url="https://kanaka.github.io/noVNC/"
@@ -22,7 +22,7 @@ package() {
cp -r "$builddir"/* .
# Clean up package.
- rm CONTRIBUTING.md utils/README.md
+ rm utils/README.md
# Move license files.
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
@@ -40,5 +40,5 @@ package() {
rm -r utils
}
-sha512sums="245d205f8935c82722a55d6cfcd2cea1825176c0cd695fd0eec34aa19cdc3b766fed62e741ff41b0a8c4a3b3cbabc5a39dfa6ad8ffa6169f5b88420a4a845a7c novnc-0.6.2.tar.gz
-e3a444d8a8cbf742bc1299e229deb129bcb6045eef1aad20e8db066362db1da77a59130fdadfffffbc69a5cb4c5a929eb4d40382305dae5fc4ab5f09f9d9eef6 alpine-specific-launch.js.patch"
+sha512sums="97a86be5f10f382e2ed641360f5f6c3b22998f68f980c78138aca900ef6a011c1f6aa9cbdd8cd07afd4884e8c65af30d65487e87bb34e524c10f16cf4cd116a3 novnc-1.0.0.tar.gz
+d4fba29910c81a52af176cc9af533660a2b09a7846d9857824db0a9b5395712ae99ebd1d96a7cb3c29a58b7aad78876c88e14b847d6cb542cf9cb2991730c935 alpine-specific-launch.js.patch"
diff --git a/testing/novnc/alpine-specific-launch.js.patch b/testing/novnc/alpine-specific-launch.js.patch
index 0228469d04..1c3861e110 100644
--- a/testing/novnc/alpine-specific-launch.js.patch
+++ b/testing/novnc/alpine-specific-launch.js.patch
@@ -1,23 +1,6 @@
--- a/utils/launch.sh
+++ b/utils/launch.sh
-@@ -1,4 +1,4 @@
--#!/usr/bin/env bash
-+#!/bin/ash
-
- # Copyright 2016 Joel Martin
- # Copyright 2016 Solly Ross
-@@ -25,8 +25,8 @@
- exit 2
- }
-
--NAME="$(basename $0)"
--REAL_NAME="$(readlink -f $0)"
-+NAME="$(basename "$0")"
-+REAL_NAME="$(readlink -f "$0")"
- HERE="$(cd "$(dirname "$REAL_NAME")" && pwd)"
- PORT="6080"
- VNC_DEST="localhost:5900"
-@@ -106,42 +106,11 @@
+@@ -110,42 +110,11 @@
echo "Warning: could not find self.pem"
fi
@@ -38,7 +21,7 @@
- if [[ $? -ne 0 ]]; then
- echo "No installed websockify, attempting to clone websockify..."
- WEBSOCKIFY=${HERE}/websockify/run
-- git clone https://github.com/kanaka/websockify ${HERE}/websockify
+- git clone https://github.com/novnc/websockify ${HERE}/websockify
-
- if [[ ! -e $WEBSOCKIFY ]]; then
- echo "Unable to locate ${HERE}/websockify/run after downloading"
@@ -53,8 +36,8 @@
-
echo "Starting webserver and WebSockets proxy on port ${PORT}"
-#${HERE}/websockify --web ${WEB} ${CERT:+--cert ${CERT}} ${PORT} ${VNC_DEST} &
--${WEBSOCKIFY} --web ${WEB} ${CERT:+--cert ${CERT}} ${PORT} ${VNC_DEST} &
-+websockify --web ${WEB} ${CERT:+--cert ${CERT}} ${PORT} ${VNC_DEST} &
+-${WEBSOCKIFY} ${SSLONLY} --web ${WEB} ${CERT:+--cert ${CERT}} ${PORT} ${VNC_DEST} &
++${HERE}/websockify --web ${WEB} ${CERT:+--cert ${CERT}} ${PORT} ${VNC_DEST} &
proxy_pid="$!"
sleep 1
-if ! ps -p ${proxy_pid} >/dev/null; then