aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Morgan <jumanjiman@gmail.com>2016-02-01 01:49:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-10 10:20:52 +0000
commit4e6963994f25637ed5d61050ac4905b47c30d098 (patch)
tree6b8d749bae72546ae7220bafbc25615639c2a197
parent0652a487124c622df7f72c3d574e1dd90bae0bff (diff)
downloadaports-4e6963994f25637ed5d61050ac4905b47c30d098.tar.bz2
aports-4e6963994f25637ed5d61050ac4905b47c30d098.tar.xz
protect tabs in APKBUILD files
If a user has an editorconfig plugin for their editor, it will enforce tabs instead of spaces for indentation for APKBUILD files. It ignores other files in the repo.
-rw-r--r--.editorconfig14
1 files changed, 14 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 0000000000..85d4df20ce
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,14 @@
+; This file is for unifying the coding style for different editors and IDEs.
+; Plugins are available for notepad++, emacs, vim, gedit,
+; textmate, visual studio, and more.
+;
+; See http://editorconfig.org for details.
+
+# Top-most EditorConfig file.
+root = true
+
+[**/APKBUILD]
+indent_style = tab
+end_of_line = lf
+insert_final_newline = true
+trim_trailing_whitespace = true