aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2018-02-10 17:02:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-02-13 14:11:32 +0000
commit598de2d358add9aea2739f84c666a5e312f49349 (patch)
treee81cddb95af482151310a5a6fb4c40691e89ff9a
parentc26eac5ea1b2f63bf26a2293281575e106dcaa2b (diff)
downloadaports-598de2d358add9aea2739f84c666a5e312f49349.tar.bz2
aports-598de2d358add9aea2739f84c666a5e312f49349.tar.xz
main/py-pylast: upgrade to 2.1.0
-rw-r--r--main/py-pylast/APKBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/main/py-pylast/APKBUILD b/main/py-pylast/APKBUILD
index 26e66648fd..88a516fa4d 100644
--- a/main/py-pylast/APKBUILD
+++ b/main/py-pylast/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-pylast
-pkgver=1.9.0
+pkgver=2.1.0
pkgrel=0
pkgdesc="A Python interface to the last.fm API"
url="https://github.com/pylast/pylast"
arch="noarch"
license="Apache"
+# Requires packages which are not available for test
+options="!check"
makedepends="python2-dev py-setuptools python3-dev"
subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
source="https://files.pythonhosted.org/packages/source/p/pylast/pylast-$pkgver.tar.gz"
@@ -14,8 +16,14 @@ builddir="$srcdir"/pylast-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
}
package() {
@@ -41,4 +49,4 @@ _py3() {
_py python3
}
-sha512sums="ff3929583d88466738c9a1e964676652717c9f5bd4631f1a0a7855903e77cd394a612b0e2e8fc2f698ac84a34a135f4e940ff7760c2c88bf388ae56fc9c3da65 pylast-1.9.0.tar.gz"
+sha512sums="b33b9f644bf3fccb46a17cfe53020a2842dd9bcdf6b859353adf306a987f4d10a76554da95e832ab813f00deb2947684b276674798d67aab2cdb0cb9a141853e pylast-2.1.0.tar.gz"