aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-22 01:50:42 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 17:30:31 -0300
commit5a8c200719147577344536a944fe7f24e0f4282d (patch)
treed5723652178acfc74af00481f58eff3cf96f93b3
parent1de0416f637b4b50f049e18472e89cfb64891558 (diff)
downloadaports-5a8c200719147577344536a944fe7f24e0f4282d.tar.bz2
aports-5a8c200719147577344536a944fe7f24e0f4282d.tar.xz
testing/ponyc: upgrade to 0.32.0
-rw-r--r--testing/ponyc/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/testing/ponyc/APKBUILD b/testing/ponyc/APKBUILD
index 4185270d87..6d74387db9 100644
--- a/testing/ponyc/APKBUILD
+++ b/testing/ponyc/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=ponyc
-pkgver=0.30.0
+pkgver=0.32.0
pkgrel=0
pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
url="https://www.ponylang.org"
@@ -12,15 +12,15 @@ _llvmver=6
depends="binutils-gold"
checkdepends="openssl-dev pcre2-dev"
# Ponyc _is_ compatible with LLVM7, but LLVM7 is pretty buggy on musl.
-makedepends="libexecinfo-dev llvm${_llvmver}-dev ncurses-dev paxmark
+makedepends="libexecinfo-dev llvm$_llvmver-dev ncurses-dev paxmark
zlib-dev linux-headers"
options="!check"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/$pkgname/archive/$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/ponyc/archive/$pkgver.tar.gz
more-portable-ln.patch
makefile-remove-march-mtune.patch"
-export LLVM_CONFIG=/usr/lib/llvm${_llvmver}/bin/llvm-config
+export LLVM_CONFIG=/usr/lib/llvm$_llvmver/bin/llvm-config
# Required to not crash gold: https://sourceware.org/bugzilla/show_bug.cgi?id=23856
export CFLAGS="$CFLAGS -fPIE"
@@ -71,6 +71,6 @@ dev() {
mv "$pkgdir"/usr/lib/pony/$pkgver/include "$subpkgdir"/usr
}
-sha512sums="fbf59a687e85d02ddcc5c8f56911005e2aaa5721c97f17f1cb5209f7a8de8e19182dce6aa2d6a9373d03e4cd7161ee595b3229b3b2443dbd647d59ce4e6cc435 ponyc-0.30.0.tar.gz
+sha512sums="16fb61d952017e9c40dd2683fd7ca78b2da1cabbf813f16374b8ab080e28c8c0cd8fd284b9eacd8e05e828dbf1ab647d4d1970be5c7aafd8d2a7e8162e768bf0 ponyc-0.32.0.tar.gz
38aa40f6000dcb823be7b542cdad8d04b6ac4cd0a4fff1a472520a7cb71631fb34e5bee74914fe559674594dd901aede91390809e143dd96c5d68a16f8ac196c more-portable-ln.patch
c78156bc68332705c41e7f4f8ff65bb77a778d8ee1685e9376473041c9c0b815e96ebc4cfd68b03c5c5c9d53cff8e6c0deba0fc19a9bcb29b7f91caaa15a0803 makefile-remove-march-mtune.patch"