aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-04-06 17:19:12 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-04-06 17:19:57 +0000
commit5bf0033dd58b6f68cce10b6b6ada70a4b49d9e89 (patch)
tree557efec094fd7250435b32a23d8bb9a8e4d553ab
parent83c5ff0113bd632fa336d994626c52a32a987d4a (diff)
downloadaports-5bf0033dd58b6f68cce10b6b6ada70a4b49d9e89.tar.bz2
aports-5bf0033dd58b6f68cce10b6b6ada70a4b49d9e89.tar.xz
community/greenbone-security-assistant: upgrade to 8.0.0
Removed unused patches
-rw-r--r--community/greenbone-security-assistant/001-malloc-trim.patch16
-rw-r--r--community/greenbone-security-assistant/003-musl-stack-size.patch27
-rw-r--r--community/greenbone-security-assistant/APKBUILD28
-rw-r--r--community/greenbone-security-assistant/cmakelist.patch (renamed from community/greenbone-security-assistant/002-cmakelist.patch)0
-rw-r--r--community/greenbone-security-assistant/musl-stack-size.patch28
-rw-r--r--community/greenbone-security-assistant/sys-siglist.patch (renamed from community/greenbone-security-assistant/000-sys_siglist.patch)10
6 files changed, 46 insertions, 63 deletions
diff --git a/community/greenbone-security-assistant/001-malloc-trim.patch b/community/greenbone-security-assistant/001-malloc-trim.patch
deleted file mode 100644
index 2d64f11178..0000000000
--- a/community/greenbone-security-assistant/001-malloc-trim.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/src/gsad_base.c b/src/gsad_base.c
-index 15433f9..6500902 100644
---- a/src/gsad_base.c
-+++ b/src/gsad_base.c
-@@ -312,8 +312,9 @@ xsl_transform_with_stylesheet (const char *xml_text,
-
- xsltFreeStylesheet (cur);
- xmlFreeDoc (res);
-+#ifdef __GLIBC__
- malloc_trim (0);
--
-+#endif
- return (char *) doc_txt_ptr;
- #else
- int content_fd;
-
diff --git a/community/greenbone-security-assistant/003-musl-stack-size.patch b/community/greenbone-security-assistant/003-musl-stack-size.patch
deleted file mode 100644
index 686cdcd453..0000000000
--- a/community/greenbone-security-assistant/003-musl-stack-size.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ru greenbone-security-assistant-7.0.2.orig/src/gsad.c greenbone-security-assistant-7.0.2/src/gsad.c
---- greenbone-security-assistant-7.0.2.orig/src/gsad.c 2017-03-09 15:59:19.000000000 +0200
-+++ greenbone-security-assistant-7.0.2/src/gsad.c 2017-03-09 16:17:28.506470054 +0200
-@@ -5488,6 +5488,7 @@
- NULL, NULL, handler, NULL, MHD_OPTION_NOTIFY_COMPLETED,
- free_resources, NULL, MHD_OPTION_LISTEN_SOCKET, unix_socket,
- MHD_OPTION_PER_IP_CONNECTION_LIMIT, 30,
-+ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
- MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
- }
-
-@@ -5513,6 +5514,7 @@
- (MHD_USE_THREAD_PER_CONNECTION | MHD_USE_DEBUG | ipv6_flag, port,
- NULL, NULL, handler, NULL, MHD_OPTION_NOTIFY_COMPLETED,
- free_resources, NULL, MHD_OPTION_SOCK_ADDR, address,
-+ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
- MHD_OPTION_PER_IP_CONNECTION_LIMIT, 30,
- MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
- }
-@@ -5540,6 +5542,7 @@
- MHD_OPTION_HTTPS_MEM_CERT, cert,
- MHD_OPTION_NOTIFY_COMPLETED, free_resources, NULL,
- MHD_OPTION_SOCK_ADDR, address,
-+ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
- MHD_OPTION_PER_IP_CONNECTION_LIMIT, 30,
- MHD_OPTION_HTTPS_PRIORITIES, priorities,
- MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL,
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
index 722fdebfc6..29175d3a3e 100644
--- a/community/greenbone-security-assistant/APKBUILD
+++ b/community/greenbone-security-assistant/APKBUILD
@@ -2,26 +2,25 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=greenbone-security-assistant
_pkgname=gsad
-pkgver=7.0.3
-pkgrel=1
+pkgver=8.0.0
+pkgrel=0
pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
url="http://www.openvas.org/"
arch="all"
-license="GPL"
+license="GPL-2.0"
depends="wget"
-makedepends="cmake doxygen xmltoman graphviz openvas-libraries-dev
- libxslt-dev libmicrohttpd-dev py3-polib libgcrypt-dev"
+makedepends="cmake doxygen xmltoman graphviz gvm-libs-dev
+ libxslt-dev libmicrohttpd-dev py2-polib libgcrypt-dev
+ nodejs-current npm yarn clang-dev"
checkdepends="cppcheck"
subpackages="$pkgname-doc $pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/gsa/archive/v${pkgver}.tar.gz
$_pkgname.initd
$_pkgname.confd
$_pkgname.logrotate
- 000-sys_siglist.patch
- 001-malloc-trim.patch
- 002-cmakelist.patch
- 003-musl-stack-size.patch"
-
+ cmakelist.patch
+ sys-siglist.patch
+ musl-stack-size.patch"
builddir="$srcdir/gsa-$pkgver"
build() {
@@ -47,11 +46,10 @@ package() {
install -Dm755 "$srcdir/$_pkgname.confd" "$pkgdir/etc/conf.d/$_pkgname"
}
-sha512sums="7e1c1ef939ba08dab3b78baf1aa9c110be2febfbed5d67eefe8110c60f5089a1af44bc26693657226f417c6bd516a4a656eb159dae2a78f878e1a1b6c222b117 greenbone-security-assistant-7.0.3.tar.gz
+sha512sums="b3bc464548d6ecef8d515e69f9824d064b90c3da677f262fb040b2750b2c15cd14dfe2c7db3f830ce9d9d8bfb7d1591cc78c1c860d7b8a3417af03c78f99813f greenbone-security-assistant-8.0.0.tar.gz
a9eeb08743ac1565dec52d117daf7d9de87e162555eb63b4142bf5957a36f2da90d3f41a96968ec581ca489099a3bb7d7f32180959282add9cbc2363c5189eb5 gsad.initd
aea96cef16ca7a63570c2d94a1fc7ef27d4163c28e1d729fd11821295f88a96864add0146d407e7b6de296dd6ca6f2c97d72097dd4ffe786b575f128abdbb1bf gsad.confd
0d459084f95e00dfb06912b9d89af011fac117a32687ffd3da3887c24e80c074b681c0d87532a4a7511e42c540f8d8b2ceaa04208fff531b94047a08decddd0f gsad.logrotate
-7074ab472761d44f401dd34feeba62c5c47f97ec9aec9a8be51bc1ceb8d32ebd4de162fb6563cd58859354dccd3f3874e5012433c81e45bfaab368188a9b481f 000-sys_siglist.patch
-e2cf8dd79a029d8c6dd7c3a67424a1b345da60582eedc7419395a751a118d0e2fbf21cd7e68db81ae5e403858107a9ecbbd4aaafa3f2b851a77c6ab953ed0dd8 001-malloc-trim.patch
-6752bb6834811fc7c1259d2c8a0ae5f25a01de881008f6f6635b1f7a43672b5c1862de5b3591f81d7a2f22258614b71bb6ab588a3930648d9d74ef8a75d28c92 002-cmakelist.patch
-509cecb54f00e09fad87cca783ba4fc0b7115be903056170884501ddbb97ec00c76c3c9369a54b6ab14e0429aa3fe2ea7c8ec091334d9b66767457075f48e4bb 003-musl-stack-size.patch"
+6752bb6834811fc7c1259d2c8a0ae5f25a01de881008f6f6635b1f7a43672b5c1862de5b3591f81d7a2f22258614b71bb6ab588a3930648d9d74ef8a75d28c92 cmakelist.patch
+1fd6585bc5c5131d19d5d89ddc56b683d5ab1b28793059f5b147ad05eb6330b69d590caa2f12afce6da20b1676d8cdd26d90e51d165e94b308643ec7d2525015 sys-siglist.patch
+5083162dd8f324e102731f691f575adb791861d13d857e37bf0e2aa39b875facae8e7b1ad37a0d60860495603df90ef785cab13685c4405d14e06aca1d8bfe5e musl-stack-size.patch"
diff --git a/community/greenbone-security-assistant/002-cmakelist.patch b/community/greenbone-security-assistant/cmakelist.patch
index 0501cb785e..0501cb785e 100644
--- a/community/greenbone-security-assistant/002-cmakelist.patch
+++ b/community/greenbone-security-assistant/cmakelist.patch
diff --git a/community/greenbone-security-assistant/musl-stack-size.patch b/community/greenbone-security-assistant/musl-stack-size.patch
new file mode 100644
index 0000000000..8a64f23557
--- /dev/null
+++ b/community/greenbone-security-assistant/musl-stack-size.patch
@@ -0,0 +1,28 @@
+diff --git a/gsad/src/gsad.c b/gsad/src/gsad.c
+index efdecfc..7d7e13d 100644
+--- a/gsad/src/gsad.c
++++ b/gsad/src/gsad.c
+@@ -2598,6 +2598,7 @@ start_unix_http_daemon (const char *unix_socket_path,
+ 0, NULL, NULL, handler, http_handlers, MHD_OPTION_NOTIFY_COMPLETED,
+ free_resources, NULL, MHD_OPTION_LISTEN_SOCKET, unix_socket,
+ MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+ MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
+ }
+
+@@ -2626,6 +2627,7 @@ start_http_daemon (int port,
+ port, NULL, NULL, handler, http_handlers, MHD_OPTION_NOTIFY_COMPLETED,
+ free_resources, NULL, MHD_OPTION_SOCK_ADDR, address,
+ MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+ MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
+ }
+
+@@ -2653,6 +2655,7 @@ start_https_daemon (int port, const char *key, const char *cert,
+ key, MHD_OPTION_HTTPS_MEM_CERT, cert, MHD_OPTION_NOTIFY_COMPLETED,
+ free_resources, NULL, MHD_OPTION_SOCK_ADDR, address,
+ MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+ MHD_OPTION_HTTPS_PRIORITIES, priorities, MHD_OPTION_EXTERNAL_LOGGER,
+ mhd_logger, NULL,
+ /* LibmicroHTTPD 0.9.35 and higher. */
diff --git a/community/greenbone-security-assistant/000-sys_siglist.patch b/community/greenbone-security-assistant/sys-siglist.patch
index 1af39b98b9..1796b38e5f 100644
--- a/community/greenbone-security-assistant/000-sys_siglist.patch
+++ b/community/greenbone-security-assistant/sys-siglist.patch
@@ -1,8 +1,8 @@
-diff --git a/src/gsad.c b/src/gsad.c
-index 73bbff2..65a0d22 100644
---- a/src/gsad.c
-+++ b/src/gsad.c
-@@ -6249,7 +6249,7 @@ main (int argc, char **argv)
+diff --git a/gsad/src/gsad.c b/gsad/src/gsad.c
+index efdecfc..5e5e1e8 100644
+--- a/gsad/src/gsad.c
++++ b/gsad/src/gsad.c
+@@ -3352,7 +3352,7 @@ main (int argc, char **argv)
{
if (termination_signal)
{