aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-03-01 22:16:10 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-03-02 01:26:19 +0100
commit5d4d4fb329c0488eea26ddd9e5eb5ac44f9464b5 (patch)
tree219550d11c015ee1cb23c531bac3f82ce2e844bc
parentb0121a0561cc1b4504af537e971af82b306ecdcb (diff)
downloadaports-5d4d4fb329c0488eea26ddd9e5eb5ac44f9464b5.tar.bz2
aports-5d4d4fb329c0488eea26ddd9e5eb5ac44f9464b5.tar.xz
community/open-vm-tools: upgrade to 11.0.5
-rw-r--r--community/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch31
-rw-r--r--community/open-vm-tools/0006-Use-configure-to-test-for-feature-instead-of-platfor.patch9
-rw-r--r--community/open-vm-tools/0008-Rename-poll.h-to-vm_poll.h.patch23
-rw-r--r--community/open-vm-tools/APKBUILD21
-rw-r--r--community/open-vm-tools/fix-mount.vmhgfs-symlink.patch11
-rw-r--r--community/open-vm-tools/mock-res_ninit-and-res_nclose.patch47
6 files changed, 85 insertions, 57 deletions
diff --git a/community/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch b/community/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch
index 39bd1587e4..349d70dd57 100644
--- a/community/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch
+++ b/community/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch
@@ -10,10 +10,9 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
2 files changed, 4 insertions(+)
diff --git a/open-vm-tools/lib/include/guest_os.h b/open-vm-tools/lib/include/guest_os.h
-index 230acd2c..55a84c4a 100644
--- a/open-vm-tools/lib/include/guest_os.h
+++ b/open-vm-tools/lib/include/guest_os.h
-@@ -223,6 +223,7 @@ Bool Gos_InSetArray(uint32 gos, const uint32 *set);
+@@ -239,6 +239,7 @@
/* Linux */
#define STR_OS_AMAZON_LINUX "amazonlinux"
@@ -22,26 +21,22 @@ index 230acd2c..55a84c4a 100644
#define STR_OS_ARCH "Arch"
#define STR_OS_ARKLINUX "Arklinux"
diff --git a/open-vm-tools/lib/misc/hostinfoPosix.c b/open-vm-tools/lib/misc/hostinfoPosix.c
-index b6ebaa7e..1e8f50f2 100644
--- a/open-vm-tools/lib/misc/hostinfoPosix.c
+++ b/open-vm-tools/lib/misc/hostinfoPosix.c
-@@ -179,6 +179,7 @@ typedef struct {
+@@ -182,6 +182,7 @@
/* KEEP SORTED! (sort -d) */
static const DistroInfo distroArray[] = {
-+ {"Alpine", "/etc/alpine-release"},
- {"Annvix", "/etc/annvix-release"},
- {"Arch", "/etc/arch-release"},
- {"Arklinux", "/etc/arklinux-release"},
-@@ -762,6 +763,8 @@ HostinfoGetOSShortName(char *distro, // IN: full distro name
-
- Str_Sprintf(distroShort, distroShortSize, "%s%d", STR_OS_AMAZON_LINUX,
- amazonMajor);
++ { "Alpine", "/etc/alpine-release" },
+ { "Annvix", "/etc/annvix-release" },
+ { "Arch", "/etc/arch-release" },
+ { "Arklinux", "/etc/arklinux-release" },
+@@ -895,6 +896,8 @@
+ Str_Strcpy(distroShort, STR_OS_TURBO, distroShortSize);
+ } else if (strstr(distroLower, "sun")) {
+ Str_Strcpy(distroShort, STR_OS_SUN_DESK, distroShortSize);
+ } else if (strstr(distroLower, "alpine")) {
+ Str_Strcpy(distroShort, STR_OS_ALPINE, distroShortSize);
- } else if (strstr(distroLower, "annvix")) {
- Str_Strcpy(distroShort, STR_OS_ANNVIX, distroShortSize);
- } else if (strstr(distroLower, "arch")) {
---
-2.19.1
-
+ } else if (strstr(distroLower, "amazon")) {
+ if (version < 2) {
+ version = 2;
diff --git a/community/open-vm-tools/0006-Use-configure-to-test-for-feature-instead-of-platfor.patch b/community/open-vm-tools/0006-Use-configure-to-test-for-feature-instead-of-platfor.patch
index 0753e68fa6..b6e1c341a2 100644
--- a/community/open-vm-tools/0006-Use-configure-to-test-for-feature-instead-of-platfor.patch
+++ b/community/open-vm-tools/0006-Use-configure-to-test-for-feature-instead-of-platfor.patch
@@ -118,10 +118,10 @@ diff --git a/open-vm-tools/lib/nicInfo/nicInfoPosix.c b/open-vm-tools/lib/nicInf
index a22981d5..ddc37e09 100644
--- a/open-vm-tools/lib/nicInfo/nicInfoPosix.c
+++ b/open-vm-tools/lib/nicInfo/nicInfoPosix.c
-@@ -34,9 +34,13 @@
- #include <sys/socket.h>
+@@ -35,9 +35,13 @@
#include <sys/stat.h>
#include <errno.h>
+ #include <limits.h>
-#if defined(__FreeBSD__) || defined(__APPLE__)
+#if HAVE_SYS_SYSCTL_H
# include <sys/sysctl.h>
@@ -133,7 +133,7 @@ index a22981d5..ddc37e09 100644
# include <net/if.h>
#endif
#ifndef NO_DNET
-@@ -456,10 +460,7 @@ GuestInfoGetNicInfo(unsigned int maxIPv4Routes,
+@@ -494,10 +498,7 @@
*
******************************************************************************
*/
@@ -145,6 +145,3 @@ index a22981d5..ddc37e09 100644
char *
GuestInfoGetPrimaryIP(void)
---
-2.19.1
-
diff --git a/community/open-vm-tools/0008-Rename-poll.h-to-vm_poll.h.patch b/community/open-vm-tools/0008-Rename-poll.h-to-vm_poll.h.patch
index d3d00a459b..4b89923f29 100644
--- a/community/open-vm-tools/0008-Rename-poll.h-to-vm_poll.h.patch
+++ b/community/open-vm-tools/0008-Rename-poll.h-to-vm_poll.h.patch
@@ -7,16 +7,6 @@ musl libc's system headers pulls in open-vm-tools' poll.h. To avoid this
we rename poll.h to vm_poll.h.
Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- open-vm-tools/lib/asyncsocket/asyncsocket.c | 2 +-
- open-vm-tools/lib/hgfsServer/hgfsServer.c | 2 +-
- open-vm-tools/lib/include/asyncsocket.h | 2 +-
- open-vm-tools/lib/include/pollImpl.h | 2 +-
- open-vm-tools/lib/include/{poll.h => vm_poll.h} | 0
- open-vm-tools/lib/rpcIn/rpcin.c | 2 +-
- .../services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c | 2 +-
- 7 files changed, 6 insertions(+), 6 deletions(-)
- rename open-vm-tools/lib/include/{poll.h => vm_poll.h} (100%)
diff --git a/open-vm-tools/lib/asyncsocket/asyncsocket.c b/open-vm-tools/lib/asyncsocket/asyncsocket.c
index 65b07109..54662189 100644
@@ -87,19 +77,6 @@ index 8eea7d86..c48f5be2 100644
# include "asyncsocket.h"
# include "vmci_defs.h"
#include "dataMap.h"
-diff --git a/open-vm-tools/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c b/open-vm-tools/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
-index 03700937..f0b49ad7 100644
---- a/open-vm-tools/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
-+++ b/open-vm-tools/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
-@@ -48,7 +48,7 @@
- #include "rpcout.h"
- #include "rabbitmqProxyConst.h"
- #include "vm_basic_types.h"
--#include "poll.h"
-+#include "vm_poll.h"
- #ifdef OPEN_VM_TOOLS
- #include "vmci_sockets.h"
- #include "sslDirect.h"
--
2.19.1
diff --git a/community/open-vm-tools/APKBUILD b/community/open-vm-tools/APKBUILD
index 99d4abeddd..3d45427777 100644
--- a/community/open-vm-tools/APKBUILD
+++ b/community/open-vm-tools/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=open-vm-tools
-pkgver=10.3.10
+pkgver=11.0.5
_pkgsubver=${pkgver#*_p}
_ver=${pkgver/_p/-}
-pkgrel=4
+pkgrel=0
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="https://github.com/vmware/open-vm-tools/"
arch="x86 x86_64"
@@ -29,9 +29,10 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vmware/open-vm-tools/archive
0009-gnu-ucontext.patch
0010-use-posix-strerror_r-unless-gnu.patch
0011-use-off64_t-instead-of-loff_t.patch
- 0012-remove-references-to-missing-common-agent-etc-config.patch
strerror_r.patch
systemLinux.c-fixup-for-Alpine.patch
+ mock-res_ninit-and-res_nclose.patch
+ fix-mount.vmhgfs-symlink.patch
$pkgname.initd
$pkgname.confd
@@ -67,7 +68,6 @@ build() {
--without-dnet \
--without-xerces \
--with-icu \
- --with-procps \
--with-x \
--without-kernel-modules \
--without-pam \
@@ -84,7 +84,7 @@ package() {
cd "$pkgdir"
- chmod -x ./etc/vmware-tools/*.conf
+ chmod -x ./etc/vmware-tools/*.conf*
mv ./etc/vmware-tools/vm-support ./usr/bin/vm-support
install -D -m 755 "$srcdir"/$pkgname.initd \
@@ -125,21 +125,22 @@ gtk() {
"$subpkgdir"/usr/lib/open-vm-tools/plugins/vmsvc/
}
-sha512sums="0e3125be5514a006dd4303057201c5922e4e3654ec1ef12d1effb94716ac4d45495cc110724c8d8e16855437dab6b596bc79c69a8789fb3eb20576f99b8d76cf open-vm-tools-10.3.10.tar.gz
-5aa0d21bd4e1e7e4791677e02d0a50ad1800c1a5507044c9d693c59cc2360c423eba25643fba615f597b6dafad0e9551b775cf144b63051b68c934e911b5caed 0001-lib-misc-Recognize-Alpine-Linux.patch
+sha512sums="c09e5b66f318273c712880f8b8bfe9782f6302e798808eb588f643cfca763b6805d5672a95fc3c87bf18dd4549f7a0cdebf9b9ca313cf761a72864748895fab9 open-vm-tools-11.0.5.tar.gz
+fe56bb4a57f228081d28dede1f25d6de73fcdb9276a704354d24711aaf47fe2399f81202afd0a33f6eeda1117067fea0cfc9e3eb97e35a3a7fddfa54056c273f 0001-lib-misc-Recognize-Alpine-Linux.patch
9188161f9bbd6572ee20855e727257b2140b39f1ba19b96879eb9878fb08cbdb7c3a5c9f5f8a4f389090acea6f71ee88fb36c7d4a74c1b8b94c9124db696a7f2 0002-open-vm-tools-Add-disable-werror-configure-option.patch
1dd0cde6ee19aec77ddf803e95b0404e803569a38c7b3d001832b4bbeae95ea15ed32c59f27bffb315130bad0c7a788a7a522df13a5f265f66c4c7c302a1966d 0003-Do-not-assume-that-linux-and-gnu-libc-are-the-same-t.patch
c647561c72b3ad919502ec4dd0a1ab736e2d479d8437b882791adce5417d8c26163ecffe9e212dab633c513bce6447cdbcb610eecf7dbb0eeeb792db16301de5 0004-Use-configure-test-for-struct-timespec.patch
6b0b9cc4a7b9837649a01aacb957b4465ec901250e48dbb273514abedf8eb3a9c16b3ad09be413a8ab897e37dff0d065a3144a2418cd7ae5aa3020bd1ed14203 0005-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch
-58f68cef6c6388a3f1b66758af81c2818abb43222c140ce95419c94bb9aaf42102275844c18b9743c758f1984e8de6c92801348593e1a3e47f813316c4cc866b 0006-Use-configure-to-test-for-feature-instead-of-platfor.patch
+4d6ce73d7e3fa554e31d7956b26e1d0341b57ff477d3e1386f30d7e1acb38cf3f6d8a3f918a484f64acf3e5c0f2ef898027963b8b87949669d3308eb9c185d82 0006-Use-configure-to-test-for-feature-instead-of-platfor.patch
9d28eab3e1a40138efa05e78956a2615b171703f9689252d0960145e39b0ba5bbf0e2007479cbbca3dced89ccb45758908a57a2f5b361e4813ad67a0732e4539 0007-Use-configure-test-for-sys-stat.h-include.patch
-ff807233d0d1b15897d012080851007d23ad6e19c76eb85c9f63673491a4ff622a7d69d99c4a23ffe0fb4a24e57faf9cd1b1c2cce055a532d940dd3462168990 0008-Rename-poll.h-to-vm_poll.h.patch
+03579b28ecc446c6a16256be8b53dcb9b5f90d05ea52aad77997f2a7957d63af546182872b2ad2ed2f99904a22be23fc64ced4ecac91a53646d9946bd6d13625 0008-Rename-poll.h-to-vm_poll.h.patch
88a8dcb785723c6120aed19e46c7f9890858a4b60db4a86e97fe4babf7b0d8babb3b3294f9d6c0004c6ae0c75860c3a624e6446f6e0d1a23bb92578f92120352 0009-gnu-ucontext.patch
6c8b99f51bc0fd114ce66a3311f151efbe56ec308d079afec837b9d0b60eae3fb42e1b5219246c1015a23fb63616398b958e1388830b80d5efdb27cce7bd6552 0010-use-posix-strerror_r-unless-gnu.patch
a38bb2ac16657be9f7e9b2a5e32d23e66db1f283284c1cb8e7ffe853e047373397e60f01e735a28ecfaa60010f285b0b5a4066465a2afbe643a9b4b9b74ac1f4 0011-use-off64_t-instead-of-loff_t.patch
-ae00f77279a76f0d5205e7c6e8e2a9abd8fd1590244a907792c9be003c38c057eee015aba3e79bd956b4197dc03b7a6eb3935620f3d3cbc4d4e7c62187ae76ce 0012-remove-references-to-missing-common-agent-etc-config.patch
5507a58198179805e4c924b6bd6ac8b026bd602c9e5e4c52213dadf6c8880a23a16ee49a4dfe2db27515c2a36009e609dd81b7ee0d560bbea1ddf6a5324eb7ac strerror_r.patch
c18280eb3fdfe1e3ecc5aa116369908c71917bd4dd49743a9abf78e0096e8d6c7d4323057cf506ef31886b893b2e4c4839656172edd5097a347efa96aea1c86c systemLinux.c-fixup-for-Alpine.patch
+8288503c54c5a15268b1590d747d4f246fa348734ebc70f3bd56f8cec6419d032ee6bf52a7579ee088f2c80f5b0d85f050e0615d6ad6cd8da016efa2a626ce17 mock-res_ninit-and-res_nclose.patch
+dbcec24beafbbe94c8ed12482f9d0c643a6bbec256198cdc898513410271a3e2c0b7e35b0997ee0e91b1567f4ed0ecf44740b8c972dd5b2fc4bf21643653153a fix-mount.vmhgfs-symlink.patch
d4d0c0c3042eef4d241c933de6f7c398a88275744b3576efc2f909acd681752f548e4ae4a17eca7db731ee0b9254b46169a48463d12a72ec6354065d788159f4 open-vm-tools.initd
ffc9c945a41e48791bab61ba72fed96c1a6ae3722caa715424e3077d167421b4e2f53bb4d415ab227d1f6e40d6ca3779df41e6b0a38db34b520979fa2b19298d open-vm-tools.confd
5626c68b8ee01ece804f314b829476280e892581a448c27092e32a60b04d40ecfa8e8eca464c4376c3cfc497eb60406798b7383d1a747a173d3cd8b78d23100b open-vm-tools.logrotate"
diff --git a/community/open-vm-tools/fix-mount.vmhgfs-symlink.patch b/community/open-vm-tools/fix-mount.vmhgfs-symlink.patch
new file mode 100644
index 0000000000..9e7acf55d3
--- /dev/null
+++ b/community/open-vm-tools/fix-mount.vmhgfs-symlink.patch
@@ -0,0 +1,11 @@
+--- a/open-vm-tools/hgfsmounter/Makefile.am
++++ b/open-vm-tools/hgfsmounter/Makefile.am
+@@ -40,7 +40,7 @@
+ else
+ install-exec-hook:
+ -$(MKDIR_P) $(DESTDIR)/sbin
+- -$(LN_S) $(DESTDIR)$(sbindir)/mount.vmhgfs \
++ -$(LN_S) ..$(sbindir)/mount.vmhgfs \
+ $(DESTDIR)/sbin/mount.vmhgfs &> /dev/null
+ uninstall-hook:
+ rm -f $(DESTDIR)/sbin/mount.vmhgfs
diff --git a/community/open-vm-tools/mock-res_ninit-and-res_nclose.patch b/community/open-vm-tools/mock-res_ninit-and-res_nclose.patch
new file mode 100644
index 0000000000..0537106b03
--- /dev/null
+++ b/community/open-vm-tools/mock-res_ninit-and-res_nclose.patch
@@ -0,0 +1,47 @@
+This patch is based on community/qt5-qtwebengine/qt-musl-resolve.patch.
+
+--- a/open-vm-tools/lib/nicInfo/nicInfoPosix.c
++++ b/open-vm-tools/lib/nicInfo/nicInfoPosix.c
+@@ -66,6 +66,10 @@
+ #include <arpa/nameser.h>
+ #include <resolv.h>
+
++#if !defined(__GLIBC__)
++# include "resolv_compat.h"
++#endif
++
+ #ifdef __linux__
+ # include <net/if.h>
+ #endif
+--- /dev/null
++++ b/open-vm-tools/lib/nicInfo/resolv_compat.h
+@@ -0,0 +1,29 @@
++#if !defined(__GLIBC__)
++/***************************************************************************
++ * resolv_compat.h
++ *
++ * Mimick GLIBC's res_ninit() and res_nclose() for musl libc
++ * Note: res_init() is actually deprecated according to
++ * http://docs.oracle.com/cd/E36784_01/html/E36875/res-nclose-3resolv.html
++ **************************************************************************/
++#include <string.h>
++
++static inline int res_ninit(res_state statp)
++{
++ int rc = res_init();
++ if (statp != &_res) {
++ memcpy(statp, &_res, sizeof(*statp));
++ }
++ return rc;
++}
++
++static inline int res_nclose(res_state statp)
++{
++ if (!statp)
++ return -1;
++ if (statp != &_res) {
++ memset(statp, 0, sizeof(*statp));
++ }
++ return 0;
++}
++#endif