aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavel Demin <pavel-demin@outlook.com>2019-02-08 20:32:41 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-11 10:35:18 +0000
commit5f01dbf64eb5adfaabcf4f470477bae6fb677dcf (patch)
treeab8d3a238270f8e28792d9aba12a9dc1d19aba93
parent90dc123c9c8b387527664867b6fa25235c6b3a65 (diff)
downloadaports-5f01dbf64eb5adfaabcf4f470477bae6fb677dcf.tar.bz2
aports-5f01dbf64eb5adfaabcf4f470477bae6fb677dcf.tar.xz
main/gpsd: fix PPS functionality
-rw-r--r--main/gpsd/APKBUILD2
-rw-r--r--main/gpsd/gpsd-use-local-timepps-header.patch28
2 files changed, 12 insertions, 18 deletions
diff --git a/main/gpsd/APKBUILD b/main/gpsd/APKBUILD
index d27e57b5c3..ebff72c77a 100644
--- a/main/gpsd/APKBUILD
+++ b/main/gpsd/APKBUILD
@@ -77,7 +77,7 @@ _clients() {
sha512sums="b381b177fcd29089a61aa11f5df2c67473720a6bbc5590ca1c4fda627331c407de01c62caceeddae780626b9a02392e9a770d52a143357e1babdcc2fbff0ed38 gpsd-3.18.1.tar.gz
eb11fc19243d1789016d88eb7645bfe67c46304547781489bf36eb1dd4c252d523681ff835a6488fa0ef62b6b9e2f781c672279f4439f5d5640a3f214a113048 timepps.h
-ca534795df3033f15a2cd2f8cc6de5d71608f30418887f31df6dc1db1f283d5cf82920923a1a4adbcaa147e9e32458eee46aed3d64a9a83c950bb83d5e9d4f6e gpsd-use-local-timepps-header.patch
+b918e4b32a6e8bcd25d126e4f1a78dfdda30837a64e7d829f04b27e138843a1dbec83e64677edd6f88eca8cead511949ee664066de4429641ba248fe5a7768ef gpsd-use-local-timepps-header.patch
ab64ec2e28a00d94e71218462b755131f4c5c7ac39db5e914135c9009a3b8d7dca2b5762ea0b9b5859785294ed0db42234ff044ef82185b2c08f96a9ba50f4f0 0001-workaround-for-scons-using-python2.patch
e2af8f52fc2d7e663882b6d12c5f4d709aa267b16eb9aeca2a70d8ecc681ae72359f3efcd1636cde576bc8579e008f242574bc0adfab7252d3e763f039e86135 ttydefaults.patch
a0e7bf206ad51c31195f86f79ef92adca425d7f988534c0f70a2dd3053613f6fc46820d62d0330aaef7ca100b5f2ab781ce9643f25b4c99c844ae66e7eec5cbc gpsd.initd
diff --git a/main/gpsd/gpsd-use-local-timepps-header.patch b/main/gpsd/gpsd-use-local-timepps-header.patch
index ea27de7a3e..5ea6a87626 100644
--- a/main/gpsd/gpsd-use-local-timepps-header.patch
+++ b/main/gpsd/gpsd-use-local-timepps-header.patch
@@ -1,19 +1,13 @@
-diff --git a/ppsthread.c b/ppsthread.c
-index 6819c6f..45002cb 100644
---- a/ppsthread.c
-+++ b/ppsthread.c
-@@ -75,12 +75,11 @@
- */
- #define FAKE_PPS_NAME "ktimer"
+diff --git a/SConstruct b/SConstruct
+index b8f3fb1..bfe3457 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -306,7 +306,7 @@ for var in import_env:
+ envs[var] = os.environ[var]
+ envs["GPSD_HOME"] = os.getcwd()
--#if defined(HAVE_SYS_TIMEPPS_H)
-+// We supply our own timepps.h for Linux
- // include unistd.h here as it is missing on older pps-tools releases.
- // 'close' is not defined otherwise.
- #include <unistd.h>
--#include <sys/timepps.h>
--#endif
-+#include "sys/timepps.h"
+-env = Environment(tools=["default", "tar", "textfile"], options=opts, ENV=envs)
++env = Environment(tools=["default", "tar", "textfile"], options=opts, ENV=envs, CPPPATH=".")
- #include "timespec.h"
- #include "ppsthread.h"
+ # Minimal build turns off every option not set on the command line,
+ if ARGUMENTS.get('minimal'):