aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-07-24 13:08:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-24 13:13:37 +0000
commit5ff3c059459eaf7a71559f1268b9af4aa75e498f (patch)
tree43a8428bc359e2f64267f07b313d66842e5e433a
parent16751e53dc8f5e02b44866595653120aa996ef8a (diff)
downloadaports-5ff3c059459eaf7a71559f1268b9af4aa75e498f.tar.bz2
aports-5ff3c059459eaf7a71559f1268b9af4aa75e498f.tar.xz
community/gsoap: security upgrade to 2.8.50 (CVE-2017-9765)
fixes #7569
-rw-r--r--community/gsoap/APKBUILD8
-rw-r--r--community/gsoap/musl-fixes.patch25
2 files changed, 14 insertions, 19 deletions
diff --git a/community/gsoap/APKBUILD b/community/gsoap/APKBUILD
index 11e2798aa3..d4551e10b8 100644
--- a/community/gsoap/APKBUILD
+++ b/community/gsoap/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: <xmingske@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gsoap
-pkgver=2.8.45
-pkgrel=1
+pkgver=2.8.50
+pkgrel=0
arch="all"
pkgdesc='A cross-platform C and C++ SDK for SOAP/XML Web services'
license="GPL-2 gSOAP"
@@ -34,6 +34,6 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-sha512sums="db45f2f8403143387f2860339a77695079fd3224700791846eb436d510a1008fe217c85b61b980340a4982d20ed0fef87dfd8d3de07be9953b627b539ca4af2a gsoap_2.8.45.zip
-5093b720084f7bb72f6b0b25c982aaaf4f8c121b8b5e34690749ff40f5bd1ca1cc9e5adb9c597f0bfc432ca910b226f75cf22a6403820f93051e8e7191e74b07 musl-fixes.patch
+sha512sums="45bbff06083971152054571749fc7dc84962ace550154399590d8b697f0cf702c1614cbfb9f9cd23bc87b3812817abfdcaa6fc210c5daa5e8197493ce0e52a72 gsoap_2.8.50.zip
+ab917ece2b7fc507138c7920ddce99ef7a482bfef9e323366940987a75e7594ca91a081ed8d9b6a6b050346a6ebe7c9a9d2de9483beb54768384177e4bc15b9b musl-fixes.patch
a0892700b55562880a58cd8411fb3386a2ae1785c9212a59d0d1c8ccdfa86553bb8d6fb3dd6c923453a1a47c586edbc924c6e7bd4f2436948693e39bd3b1ec73 libressl.patch"
diff --git a/community/gsoap/musl-fixes.patch b/community/gsoap/musl-fixes.patch
index 52ed6efc7a..22333d1d77 100644
--- a/community/gsoap/musl-fixes.patch
+++ b/community/gsoap/musl-fixes.patch
@@ -1,6 +1,8 @@
---- ./gsoap/stdsoap2.cpp.orig
-+++ ./gsoap/stdsoap2.cpp
-@@ -18691,7 +18691,7 @@
+diff --git a/gsoap/stdsoap2.cpp b/gsoap/stdsoap2.cpp
+index fccadad..2de066f 100644
+--- a/gsoap/stdsoap2.cpp
++++ b/gsoap/stdsoap2.cpp
+@@ -19652,7 +19652,7 @@ soap_strerror(struct soap *soap)
{
#ifndef WIN32
# ifdef HAVE_STRERROR_R
@@ -9,18 +11,11 @@
return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */
# else
strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* XSI-compliant */
---- ./gsoap/stdsoap2.h.orig
-+++ ./gsoap/stdsoap2.h
-@@ -677,7 +677,7 @@
- # define SOAP_LOCALE(soap) ((soap)->c_locale ? (soap)->c_locale : ((soap)->c_locale = _create_locale(LC_ALL, "C")))
- # define SOAP_FREELOCALE(soap) (void)((soap)->c_locale && (_free_locale((soap)->c_locale), ((soap)->c_locale = NULL)))
- # else
--# if !defined(CYGWIN)
-+# if !defined(CYGWIN) && defined(__GLIBC__)
- # include <xlocale.h>
- # else
- # undef HAVE_STRTOF_L
-@@ -943,7 +943,7 @@
+diff --git a/gsoap/stdsoap2.h b/gsoap/stdsoap2.h
+index ba38ba3..9922319 100644
+--- a/gsoap/stdsoap2.h
++++ b/gsoap/stdsoap2.h
+@@ -947,7 +947,7 @@ extern "C" {
# endif
#elif defined(SOCKLEN_T)
# define SOAP_SOCKLEN_T SOCKLEN_T