aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-03-05 20:19:38 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-01 18:35:50 +0000
commit618bcf9b122cb413a6fe233fdbfef7965aa8e499 (patch)
treed066b676ef2e01504d284db1d178bd5bf489eb85
parent16b3e4e3daba819dd3a76e90cfe1c321411aa378 (diff)
downloadaports-618bcf9b122cb413a6fe233fdbfef7965aa8e499.tar.bz2
aports-618bcf9b122cb413a6fe233fdbfef7965aa8e499.tar.xz
community/liborcus: update to 0.14.1
-rw-r--r--community/liborcus/APKBUILD10
-rw-r--r--community/liborcus/boost-1.67.patch50
2 files changed, 4 insertions, 56 deletions
diff --git a/community/liborcus/APKBUILD b/community/liborcus/APKBUILD
index 3c2e67d460..6b875bfd93 100644
--- a/community/liborcus/APKBUILD
+++ b/community/liborcus/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=liborcus
-pkgver=0.13.4
-pkgrel=1
+pkgver=0.14.1
+pkgrel=0
pkgdesc="Library for processing spreadsheet documents"
url="https://gitlab.com/orcus/orcus"
arch="all"
license="MPL-2.0"
makedepends="$depends_dev boost-dev mdds-dev libixion-dev zlib-dev libixion-dev"
subpackages="$pkgname-dev"
-source="http://kohei.us/files/orcus/src/liborcus-$pkgver.tar.xz
- boost-1.67.patch
+source="https://kohei.us/files/orcus/src/liborcus-$pkgver.tar.xz
"
builddir="$srcdir/liborcus-$pkgver"
@@ -37,5 +36,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f00b49c41eb1898c37d8d42e59f9004f46b5f849b9d60ac9c5033232d1e5065ff3de160e79f5a88983bf64f86e283b6d1d406a24e776aa6ff7b8acec324ccd4b liborcus-0.13.4.tar.xz
-4a1817f70a955caa213af3ff6542b6faf0db3261406ab60b87dfc4637ab29fb1e6eb6e402911e6d5e22e29e8eb049b26c03160c8a6b802a9b842f0b8311097ba boost-1.67.patch"
+sha512sums="a32dc5a652ce99cff37273c38fb9460e13e7bfb562f40c8d0c79b65c33e340daaeeb2c796308ca700b85bfc13cc8215641563b9e9f6d44b7d61adb8e8a3c950f liborcus-0.14.1.tar.xz"
diff --git a/community/liborcus/boost-1.67.patch b/community/liborcus/boost-1.67.patch
deleted file mode 100644
index eb51fa9cd4..0000000000
--- a/community/liborcus/boost-1.67.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From f7485813af8e50f88c77312fb29b7bb489a0a17d Mon Sep 17 00:00:00 2001
-From: Adam Majer <amajer@suse.de>
-Date: Wed, 23 May 2018 10:45:56 +0200
-Subject: [PATCH] Fix build with Boost 1.67
-
-Boost:DateTime that no longer accepts non-integer types.
-In the past, these types were implicitly cast down to integer
-values. Now this requires explicit cast.
-
-https://svn.boost.org/trac10/ticket/11168
-
-This fixes #60
----
- src/spreadsheet/sheet.cpp | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/spreadsheet/sheet.cpp b/src/spreadsheet/sheet.cpp
-index 7df1aedb..33b372ad 100644
---- a/src/spreadsheet/sheet.cpp
-+++ b/src/spreadsheet/sheet.cpp
-@@ -289,7 +289,7 @@ void sheet::set_date_time(row_t row, col_t col, int year, int month, int day, in
-
- double days_since_epoch = (d - origin).days();
-
-- double ms = second * 1000000.0;
-+ long ms = second * 1000000.0;
-
- posix_time::time_duration t(
- posix_time::hours(hour) +
-@@ -606,7 +606,7 @@ date_time_t sheet::get_date_time(row_t row, col_t col) const
- if (time_fraction)
- {
- // Convert a fraction day to microseconds.
-- double ms = time_fraction * 24.0 * 60.0 * 60.0 * 1000000.0;
-+ long long ms = time_fraction * 24.0 * 60.0 * 60.0 * 1000000.0;
- posix_time::time_duration td = posix_time::microsec(ms);
-
- hours = td.hours();
-@@ -615,7 +615,7 @@ date_time_t sheet::get_date_time(row_t row, col_t col) const
-
- td -= posix_time::hours(hours);
- td -= posix_time::minutes(minutes);
-- td -= posix_time::seconds(seconds);
-+ td -= posix_time::seconds((long)seconds);
-
- ms = td.total_microseconds(); // remaining microseconds.
-
---
-2.18.0
-