aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 12:58:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:59:38 -0300
commit64514ec4e38883910239d9db884f12b7527d9850 (patch)
treecc963ff84928a9c9aed8dc93ef161e5f97df470c
parent2d0c0fedf347b63ef84ed932c60deb7ee3f3b8bc (diff)
downloadaports-64514ec4e38883910239d9db884f12b7527d9850.tar.bz2
aports-64514ec4e38883910239d9db884f12b7527d9850.tar.xz
community/openal-soft: modernize
-rw-r--r--community/openal-soft/APKBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/community/openal-soft/APKBUILD b/community/openal-soft/APKBUILD
index 2375bc06b8..2f4c209c5a 100644
--- a/community/openal-soft/APKBUILD
+++ b/community/openal-soft/APKBUILD
@@ -2,8 +2,9 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=openal-soft
pkgver=1.20.1
-pkgrel=0
+pkgrel=1
pkgdesc="software implementation of OpenAL API"
+options="!check"
url="https://kcat.strangesoft.net/openal.html"
arch="all"
license="LGPL-2.0-or-later"
@@ -11,29 +12,22 @@ depends_dev="alsa-lib-dev"
makedepends="$depends_dev linux-headers cmake"
subpackages="$pkgname-dev"
source="http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2"
-options="!check"
-
-builddir="$srcdir/$pkgname-$pkgver/build"
-
-prepare() {
- default_prepare
- mkdir -p "$builddir"
-}
build() {
local _cpuext_neon=
case "$CARCH" in
armhf) _cpuext_neon=-DALSOFT_CPUEXT_NEON=OFF;;
esac
- cmake -DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_INSTALL_LIBDIR="lib" \
- $_cpuext_neon \
- ..
- make
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ $_cpuext_neon
+ make -C build
}
package() {
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
sha512sums="a8a03a2162b5d35e66adc079e81d7fa075b83a3ee1cec3412cb40f7789263ed8bd005beefb7ef995f464dfa43aac22ea0f547b752dfc7533ed9120a95fb92513 openal-soft-1.20.1.tar.bz2"