aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-04-13 13:46:31 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-04-13 13:46:31 +0300
commit6784f21b55402e44a5da70ef16912bb19a28bd62 (patch)
tree5ddf4454354c0e66a5c9000367016faa7ff63e23
parent4ed8454ab96fd6b16fb6d65ccfde564e0dcb4eca (diff)
downloadaports-6784f21b55402e44a5da70ef16912bb19a28bd62.tar.bz2
aports-6784f21b55402e44a5da70ef16912bb19a28bd62.tar.xz
main/ghostscript: fix sse variable alignment
fixes #7138
-rw-r--r--main/ghostscript/APKBUILD6
-rw-r--r--main/ghostscript/fix-alignment.patch11
2 files changed, 15 insertions, 2 deletions
diff --git a/main/ghostscript/APKBUILD b/main/ghostscript/APKBUILD
index 91e852f541..ef5b1cdd10 100644
--- a/main/ghostscript/APKBUILD
+++ b/main/ghostscript/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=ghostscript
pkgver=9.21
-pkgrel=0
+pkgrel=1
pkgdesc="An interpreter for the PostScript language and for PDF"
url="http://ghostscript.com/"
arch="all"
@@ -14,6 +14,7 @@ subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev $pkgname-gtk"
source="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${pkgver/./}/ghostscript-$pkgver.tar.gz
ghostscript-system-zlib.patch
fix-sprintf.patch
+ fix-alignment.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -108,4 +109,5 @@ gtk() {
sha512sums="c5ff632dc9b418ebeecaae796cecbaf9ffcb84d7a1b62c1af2e6c9082f7b9f24fe9dd9f6a57bde3640f54c3036f0b99b32aac9f8ca1f489c012369ab2b72ae92 ghostscript-9.21.tar.gz
70721e3a335afa5e21d4e6cf919119010bd4544a03ab8f53f5325c173902221ad9b88c118b4bfeee80b3e1956bcdbaf4c53f64ae7fb81f5ba57dbc956750c482 ghostscript-system-zlib.patch
-beefcf395f7f828e1b81c088022c08a506e218f27535b9de01e0f0edf7979b435316c318fa676771630f6ad16ff1ab059cd68aa128ed97e5a9f2f3fa840200c4 fix-sprintf.patch"
+beefcf395f7f828e1b81c088022c08a506e218f27535b9de01e0f0edf7979b435316c318fa676771630f6ad16ff1ab059cd68aa128ed97e5a9f2f3fa840200c4 fix-sprintf.patch
+7c6f40217dc687df27ee6d33351fba12a737c2ae06d1c35208dc943776d8efa66c3e882f0b1b9aec566fad69fd28ce360cc243f1c1aa20834467e769889194f2 fix-alignment.patch"
diff --git a/main/ghostscript/fix-alignment.patch b/main/ghostscript/fix-alignment.patch
new file mode 100644
index 0000000000..2608a0a083
--- /dev/null
+++ b/main/ghostscript/fix-alignment.patch
@@ -0,0 +1,11 @@
+--- ghostscript-9.21/base/gxht_thresh.c.orig 2017-04-13 13:39:39.850641972 +0300
++++ ghostscript-9.21/base/gxht_thresh.c 2017-04-13 13:39:50.380785619 +0300
+@@ -38,7 +38,7 @@
+ /* #define PACIFY_VALGRIND */
+
+ #ifndef __WIN32__
+-#define __align16 __attribute__((align(16)))
++#define __align16 __attribute__((aligned(16)))
+ #else
+ #define __align16 __declspec(align(16))
+ #endif