aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-01 20:32:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-01 20:32:02 -0300
commit68589d3794d7f8db15ccaf1ddb515289e14772bb (patch)
treecf4709b6a1182328c669ba2c6b604f4534f74d72
parent7aa50048929eb479e7beb26e300231ae785b5652 (diff)
downloadaports-68589d3794d7f8db15ccaf1ddb515289e14772bb.tar.bz2
aports-68589d3794d7f8db15ccaf1ddb515289e14772bb.tar.xz
testing/py3-bleach: new aport
https://github.com/mozilla/bleach whitelist-based HTML sanitizing library
-rw-r--r--testing/py3-bleach/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-bleach/APKBUILD b/testing/py3-bleach/APKBUILD
new file mode 100644
index 0000000000..40bf888153
--- /dev/null
+++ b/testing/py3-bleach/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-bleach
+pkgver=3.1.0
+pkgrel=0
+pkgdesc="whitelist-based HTML sanitizing library"
+url="https://github.com/mozilla/bleach"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six py3-webencodings"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mozilla/bleach/archive/v$pkgver.tar.gz"
+builddir="$srcdir/bleach-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="125e22c27e7064702db3c72f7f9b59caf919d4eedc65111c0a901af22530416595406859d741621d4d6a52234929b820b87204f71f0e07bb46683e677140fed8 py3-bleach-3.1.0.tar.gz"