aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 23:01:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 23:01:11 -0300
commit6be6a2d7a031747c7bd4e56f4f839b5948b8bee2 (patch)
tree8b42119a80dc12a26dbc367e8fbe88e3ff1741ff
parent9b0daa8496dd8c9f33e6d4cd4a0319e6f91874c1 (diff)
downloadaports-6be6a2d7a031747c7bd4e56f4f839b5948b8bee2.tar.bz2
aports-6be6a2d7a031747c7bd4e56f4f839b5948b8bee2.tar.xz
community/syslog-summary: remove
- Python2 only - Last release from 2009
-rw-r--r--community/syslog-summary/00-fix_Makefile.patch15
-rw-r--r--community/syslog-summary/01-fix_Shebang.patch17
-rw-r--r--community/syslog-summary/02-new-python-magic.patch16
-rw-r--r--community/syslog-summary/03-socklog-compat.patch14
-rw-r--r--community/syslog-summary/04-rm-whitespace.patch85
-rw-r--r--community/syslog-summary/APKBUILD31
6 files changed, 0 insertions, 178 deletions
diff --git a/community/syslog-summary/00-fix_Makefile.patch b/community/syslog-summary/00-fix_Makefile.patch
deleted file mode 100644
index f18bb8bd87..0000000000
--- a/community/syslog-summary/00-fix_Makefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- syslog-summary-1.14/Makefile
-+++ syslog-summary-1.14/Makefile.new
-@@ -6,8 +6,12 @@
- version = $(shell grep ^version syslog-summary | cut -d\" -f2)
-
- install:
-+ install -d $(DESTDIR)/usr/bin
-+ install -d $(DESTDIR)/etc/syslog-summary
-+ install -d $(DESTDIR)/usr/share/man/man1
- install -m 755 syslog-summary $(DESTDIR)/usr/bin/syslog-summary
- install -m 644 ignore.rules $(DESTDIR)/etc/syslog-summary/ignore.rules
-+ install -m 644 syslog-summary.1 $(DESTDIR)/usr/share/man/man1
-
- uninstall:
- [ ! -f $(DESTDIR)/usr/bin/syslog-summary ] || rm -v $(DESTDIR)/usr/bin/syslog-summary
diff --git a/community/syslog-summary/01-fix_Shebang.patch b/community/syslog-summary/01-fix_Shebang.patch
deleted file mode 100644
index a14da53c07..0000000000
--- a/community/syslog-summary/01-fix_Shebang.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-From: David Paleino <dapal@debian.org>
-Subject: don't hardcode python2.5
-Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=588524
-
----
- syslog-summary | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- syslog-summary.orig/syslog-summary
-+++ syslog-summary/syslog-summary
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.5
-+#!/usr/bin/python
- # -*- coding: utf-8 -*-
-
- # Copyright © 2008-2009, David Paleino <d.paleino@gmail.com>
-
diff --git a/community/syslog-summary/02-new-python-magic.patch b/community/syslog-summary/02-new-python-magic.patch
deleted file mode 100644
index 5e0f231af5..0000000000
--- a/community/syslog-summary/02-new-python-magic.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-## use the new thread safe version of python-magic not the original ##
-
---- syslog-summary-1.14/syslog-summary
-+++ syslog-summary-1.14/syslog-summary.new
-@@ -130,9 +130,8 @@
- """Returns True if the filename is a gzipped compressed file"""
- try:
- import magic
-- ms = magic.open(magic.MAGIC_NONE)
-- ms.load()
-- if re.search("^gzip compressed data.*", ms.file(filename)):
-+ ms = magic.from_file(filename)
-+ if re.search("^gzip compressed data.*", ms):
- return True
- else:
- return False
diff --git a/community/syslog-summary/03-socklog-compat.patch b/community/syslog-summary/03-socklog-compat.patch
deleted file mode 100644
index 03a1993e28..0000000000
--- a/community/syslog-summary/03-socklog-compat.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- syslog-summary-1.14/syslog-summary
-+++ syslog-summary-1.14/syslog-summary.new
-@@ -43,6 +43,11 @@
- from optparse import OptionParser
-
- datepats = [
-+ # 1st => runit / svlogd || svlogd -t || -tt || -ttt
-+ re.compile(r"^[\@\.\-\:\_ A-Za-z0-9]{0,26}?(\w+[.]\w+): \w+[ :0-9]{12} "),
-+ # 2nd & 3rd => digit dates / mysql error logs
-+ re.compile(r"^([-/ 0-9]{10} {1,2}[:0-9]{7,8})([ 0-9]{16})? "),
-+ re.compile(r"^(InnoDB:|Tcp|Time.*Argument|Version:|mysqld,) "),
- re.compile(r"^(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec) [ 0-9][0-9] [ 0-9][0-9]:[0-9][0-9]:[0-9][0-9] "),
- re.compile(r"^(Mon|Tue|Wed|Thu|Fri|Sat|Sun) (Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec) [ 0-9][0-9][0-9][0-9]:[0-9][0-9] "),
- re.compile(r"^(Mon|Tue|Wed|Thu|Fri|Sat|Sun) (Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec) [ 0-9][0-9][0-9][0-9]:[0-9][0-9]:[0-9][0-9] "),
diff --git a/community/syslog-summary/04-rm-whitespace.patch b/community/syslog-summary/04-rm-whitespace.patch
deleted file mode 100644
index a8026da7d2..0000000000
--- a/community/syslog-summary/04-rm-whitespace.patch
+++ /dev/null
@@ -1,85 +0,0 @@
---- syslog-summary-1.14/syslog-summary
-+++ syslog-summary-1.14/syslog-summary.new
-@@ -4,22 +4,22 @@
- # Copyright © 2008-2009, David Paleino <d.paleino@gmail.com>
- # © 2001-2008, Tommi Virtanen <tv@debian.org>
- # © 1998-2000, Lars Wirzenius <liw@iki.fi>
--#
-+#
- # This program is free software; you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
- # the Free Software Foundation; either version 3 of the License, or
- # (at your option) any later version.
--#
-+#
- # This program is distributed in the hope that it will be useful,
- # but WITHOUT ANY WARRANTY; without even the implied warranty of
- # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- # GNU General Public License for more details.
--#
-+#
- # You should have received a copy of the GNU General Public License
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
- # MA 02110-1301, USA.
--
-+
- """Summarize the contents of a syslog log file.
-
- The syslog(3) service writes system log messages in a certain format:
-@@ -139,10 +139,10 @@
- return False
- except:
- from os.path import splitext
--
-+
- if not QUIET:
- print "Using fallback detection... please install python-magic for better gzip detection."
--
-+
- if splitext(filename)[1] == ".gz":
- return True
- else:
-@@ -154,7 +154,7 @@
- ignored_count = 0
- if not QUIET:
- print "Summarizing %s" % filename
--
-+
- # If the file is a gzipped log, open it
- # using the proper function from the gzip
- # module.
-@@ -165,7 +165,7 @@
- file = open(filename, "r")
- except IOError, e:
- io_error(e, filename, True)
--
-+
- linecount = 0
-
- shaobj = sha1()
-@@ -193,13 +193,13 @@
- # foo+=1
- shaobj.update(line)
- linecount += 1
--
-+
- if should_be_ignored(line):
- ignored_count += 1
- if DEBUG:
- print "Ignoring: %s" % line
- line = file.readline()
--
-+
- date, rest = split_date(line)
- if date:
- found = pidpat.search(rest)
-@@ -232,7 +232,7 @@
- # print foo
- states[filename] = (linecount + ignored_count, shaobj.hexdigest())
- # print states
--
-+
- if QUIET and order:
- print "Summarizing %s" % filename
- if not QUIET or order:
diff --git a/community/syslog-summary/APKBUILD b/community/syslog-summary/APKBUILD
deleted file mode 100644
index e36bd645ce..0000000000
--- a/community/syslog-summary/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=syslog-summary
-pkgver=1.14
-pkgrel=1
-pkgdesc="Summarize the contents of a syslog log file / useful with logcheck"
-url="https://github.com/dpaleino/syslog-summary"
-arch="noarch"
-license="GPL-3.0"
-depends="py2-magic"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/dpaleino/$pkgname/archive/$pkgver.tar.gz
- 00-fix_Makefile.patch
- 01-fix_Shebang.patch
- 02-new-python-magic.patch
- 03-socklog-compat.patch
- 04-rm-whitespace.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-sha512sums="dab82f9d5e0e452d880e7e503c1de148d902c461abaf6fc1a0768516bd010c6a4e5cdbb61fd1d6e0283d55c8de9a11d02bd5828fab31cae98b59ca336a7f1a73 syslog-summary-1.14.tar.gz
-752914623deb2a9c4aec9de3bf3a8c61e2086a40d47445ea775eba44e3e23b12fe9145afb3bdbef1d7b28604c023985a8d9c34c1914e7dfe178de65ffbfb2c49 00-fix_Makefile.patch
-6d4705bae4e095a7a877ae71525df3f8bda8daa27cdd0e534fba21cfc221c130b1567e32a64f0f4327273023f9d5e890d3365b292fa3a54e508abd8fea6332d2 01-fix_Shebang.patch
-fa6be5429ca0f72cc8e1686933f956cedf89e6476cc9a25dda066be50aa05a79be8a81ff164aa3becac9f59e9948ef203c3f6d5c3889f921471e674dfc3d5098 02-new-python-magic.patch
-f7cd09e31c24f00d867e844fc53d4f607f8b8c3642cd60c40c28dcbfbe76c787ef657f38be1372eafa22027876ae8adef9b8f471f6b557c5b1ea95554efeac50 03-socklog-compat.patch
-84394c7cb364ac1df0456bcacdb68db66827000329e874aab0f1867a6d860499f04eee7701cfcdce79ec13f341a69196d95d3505f811c8f35fbe974e364030ed 04-rm-whitespace.patch"