aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 18:18:02 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 18:18:02 +0000
commit6e3d99b9517e92d4e443c2742f5373823e9fc6c2 (patch)
treed77eef904fa07d384d560528ef74a89dcbced1ad
parent89321206ef3048d07c1e02ea977fb153f954be15 (diff)
downloadaports-6e3d99b9517e92d4e443c2742f5373823e9fc6c2.tar.bz2
aports-6e3d99b9517e92d4e443c2742f5373823e9fc6c2.tar.xz
testing/openjdk11: disable on ppc64le
Build errors: > * For target buildjdk_hotspot_variant-server_libjvm_objs_os_linux_ppc.o: > /home/buildozer/aports/testing/openjdk11/src/jdk11u-jdk-11.0.4+4/src/hotspot/os_cpu/linux_ppc/os_linux_ppc.cpp: > In function 'long unsigned int ucontext_get_trap(const ucontext_t*)': > /home/buildozer/aports/testing/openjdk11/src/jdk11u-jdk-11.0.4+4/src/hotspot/os_cpu/linux_ppc/os_linux_ppc.cpp:154:30: > error: 'void*' is not a pointer-to-object type > return uc->uc_mcontext.regs->trap; ^~ > * For target hotspot_variant-server_libjvm_objs_os_linux_ppc.o: /home/buildozer/aports/testing/openjdk11/src/jdk11u-jdk-11.0.4+4/src/hotspot/os_cpu/linux_ppc/os_linux_ppc.cpp: In function 'long unsigned int ucontext_get_trap(const ucontext_t*)': > /home/buildozer/aports/testing/openjdk11/src/jdk11u-jdk-11.0.4+4/src/hotspot/os_cpu/linux_ppc/os_linux_ppc.cpp:154:30: > error: 'void*' is not a pointer-to-object type > return uc->uc_mcontext.regs->trap; > ^~ Ref: GH-7808
-rw-r--r--testing/openjdk11/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/testing/openjdk11/APKBUILD b/testing/openjdk11/APKBUILD
index 9818372edc..dd733d3a0b 100644
--- a/testing/openjdk11/APKBUILD
+++ b/testing/openjdk11/APKBUILD
@@ -6,7 +6,7 @@ _pkgver=${pkgver/_p/+}
pkgrel=0
pkgdesc="Oracle OpenJDK 11"
url="https://hg.openjdk.java.net/jdk-updates/jdk11u"
-arch="all !x86 !armhf !armv7" # openjdk10 is not yet available on 32 bit arches
+arch="all !x86 !armhf !armv7 !ppc64le" # openjdk10 is not yet available on 32 bit arches
license="GPL-2.0 with Classpath"
makedepends="autoconf
bash