aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorviest <dev@service.viest.me>2019-10-21 19:34:02 +0800
committerAndy Postnikov <apostnikov@gmail.com>2019-10-22 14:47:48 +0300
commit6edb0fc395d64d77217461bf75cbb417b77327dc (patch)
tree74eab020b476952f731693f29bac7f1090924dd2
parent3cc4934996828c86915298c8042564caba0ebadf (diff)
downloadaports-6edb0fc395d64d77217461bf75cbb417b77327dc.tar.bz2
aports-6edb0fc395d64d77217461bf75cbb417b77327dc.tar.xz
testing/php7-pecl-xlswriter: new aport
https://pecl.php.net/package/xlswriter xlswriter is a PHP C Extension that can be used to write text, numbers, formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.
-rw-r--r--testing/php7-pecl-xlswriter/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/php7-pecl-xlswriter/APKBUILD b/testing/php7-pecl-xlswriter/APKBUILD
new file mode 100644
index 0000000000..535cae2360
--- /dev/null
+++ b/testing/php7-pecl-xlswriter/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: viest <dev@service.viest.me>
+# Maintainer: viest <dev@service.viest.me>
+pkgname="php7-pecl-xlswriter"
+_pkgreal=xlswriter
+pkgver="1.3.1"
+pkgrel=0
+pkgdesc="A PHP Extension for creating and reader XLSX files. "
+url="https://pecl.php.net/package/xlswriter"
+arch="all"
+license="BSD-2-Clause"
+depends="php7-common"
+makedepends="php7-dev zlib-dev"
+source="$pkgname-$pkgver.tar.gz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir"/$_pkgreal-$pkgver
+
+build() {
+ phpize7
+ ./configure \
+ --enable-reader \
+ --prefix=/usr \
+ --with-php-config=/usr/bin/php-config7
+ make
+}
+
+check() {
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir/" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="9d14c9ae0d7a757fba9de4a4d241914778ce106d82f5349c239e2954bc95744714c5e7e87cfc87e28a733dbf917384e3b1afe1bfedf46ec94f5ce5dad963a5f7 php7-pecl-xlswriter-1.3.1.tar.gz"