aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-16 21:22:18 +0300
committerprspkt <prspkt@protonmail.com>2019-06-16 22:30:21 +0300
commit705037356d5a6a79133f306164e16beb5f5a65af (patch)
tree982f250bf9ca6172a39ec7bd7ce163c3842da256
parent5859b47f14ac7c501b06ba49f67e83a76ab2069d (diff)
downloadaports-705037356d5a6a79133f306164e16beb5f5a65af.tar.bz2
aports-705037356d5a6a79133f306164e16beb5f5a65af.tar.xz
testing/py3-github3: clarify license, modernize
-rw-r--r--testing/py3-github3/APKBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/testing/py3-github3/APKBUILD b/testing/py3-github3/APKBUILD
index c97a5aab0a..e8edd8789c 100644
--- a/testing/py3-github3/APKBUILD
+++ b/testing/py3-github3/APKBUILD
@@ -7,29 +7,21 @@ pkgrel=0
pkgdesc="Python wrapper for the GitHub API"
url="https://github3py.readthedocs.org/"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="py3-dateutil py3-jwcrypto py3-requests py3-uritemplate"
-depends_dev=""
makedepends="py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-github3" # Backwards compatibility
provides="py-github3=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="021890b36a21cf7d05c2ec8c7608eee9 github3.py-0.9.1.tar.gz"
-sha256sums="0708a306ff13be3895e3f17ef65b6e290bdc159a78ff4ad6ef43043c1b759d9d github3.py-0.9.1.tar.gz"
sha512sums="f978eade8a0c1004c45f0085873704ba8dbc885721c1c7ed99f0c3973b5f453a0a3a43dfe29cfa0be87c3cb505f7b72a7f683e4fd812c0fe6e9c9ac99256bb5e github3.py-0.9.1.tar.gz"