aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-17 16:04:30 +0200
committerTBK <tbk@jjtc.eu>2020-04-19 09:51:06 +0000
commit71a9d0734c9d7c7c0116272c05d2aaaa5102357e (patch)
tree03ff8c84a3aad412ab3c6917d4a8b03019047ed4
parentfb9980915264bfe55da0616f31541dd3edd35ce0 (diff)
downloadaports-71a9d0734c9d7c7c0116272c05d2aaaa5102357e.tar.bz2
aports-71a9d0734c9d7c7c0116272c05d2aaaa5102357e.tar.xz
testing/lrdf: new aport
https://github.com/swh/LRDF RDF library for accessing plugin metadata in the LADSPA plugin system
-rw-r--r--testing/lrdf/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/lrdf/APKBUILD b/testing/lrdf/APKBUILD
new file mode 100644
index 0000000000..0581af5ea4
--- /dev/null
+++ b/testing/lrdf/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=lrdf
+pkgver=0.6.1
+pkgrel=0
+pkgdesc="RDF library for accessing plugin metadata in the LADSPA plugin system"
+url="https://github.com/swh/LRDF"
+arch="all"
+license="GPL-2.0-only"
+makedepends="autoconf automake libtool raptor2-dev"
+subpackages="$pkgname-static $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/swh/LRDF/archive/v0.6.1.tar.gz"
+builddir="$srcdir/LRDF-$pkgver"
+options="!check" # remove_test not working: https://github.com/swh/LRDF/issues/15
+
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7732813eec704aef984d056de254e4fa049fdd0a7444b6a88f75f012afe9c587cbd1295f027c77361fa42bc097cdce9d9cabdba6b86e99a3c14805d84258df1c lrdf-0.6.1.tar.gz"