aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-18 07:15:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-18 07:15:13 +0000
commit72c72694180ee002cb38aca3899d90766ece7671 (patch)
treec2c91b26edd42c23d2edef8fec31c992afd84dbc
parent6b1a220057a90e8e71a119abce7da26b7c4b8d94 (diff)
downloadaports-72c72694180ee002cb38aca3899d90766ece7671.tar.bz2
aports-72c72694180ee002cb38aca3899d90766ece7671.tar.xz
extra/gperf: new aport
Perfect hash function generator. http://www.gnu.org/software/gperf/
-rw-r--r--extra/gperf/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/extra/gperf/APKBUILD b/extra/gperf/APKBUILD
new file mode 100644
index 0000000000..5e0509d882
--- /dev/null
+++ b/extra/gperf/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gperf
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="Perfect hash function generator."
+url="http://www.gnu.org/software/gperf/"
+license="GPL"
+subpackages="$pkgname-doc"
+depends="uclibc libgcc uclibc++"
+makedepends="uclibc++-dev"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ export CXX=g++-uc
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="cc20e58975a38075440423c8fb85fd00 gperf-3.0.3.tar.gz"