aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-25 13:16:47 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-25 11:40:45 -0300
commit72dba327e716bd529fb3ddd6f327f8cfe2d2ca72 (patch)
treee5091080aca799fcfc676974f573a765edaa32ea
parentc51897f8c09634fa306404c27ed01df0c09b0c41 (diff)
downloadaports-72dba327e716bd529fb3ddd6f327f8cfe2d2ca72.tar.bz2
aports-72dba327e716bd529fb3ddd6f327f8cfe2d2ca72.tar.xz
testing/libkcompactdisc: new aport
-rw-r--r--testing/libkcompactdisc/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/libkcompactdisc/APKBUILD b/testing/libkcompactdisc/APKBUILD
new file mode 100644
index 0000000000..18edd1f623
--- /dev/null
+++ b/testing/libkcompactdisc/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libkcompactdisc
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/multimedia/"
+pkgdesc="Library for interfacing with CDs"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev solid-dev ki18n-dev phonon-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="b58cf81c436f30a1f3daa4a365978cf4fa411af89449daf1c299e29639dfa4a537d274b44800b822329805c1696599d8265048ccc4488cc290866730cffbcb00 libkcompactdisc-19.04.2.tar.xz"