aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 10:10:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 10:17:32 -0300
commit75c4f76c0c205397286c9184282f792d747470cb (patch)
treef7b161d42e8cade0386479470de374d6e827bf80
parent67f545151141177d0f38d00bd6846b1c37eac450 (diff)
downloadaports-75c4f76c0c205397286c9184282f792d747470cb.tar.bz2
aports-75c4f76c0c205397286c9184282f792d747470cb.tar.xz
testing/py3-elasticsearch: drop py2
-rw-r--r--testing/py3-elasticsearch/APKBUILD50
1 files changed, 13 insertions, 37 deletions
diff --git a/testing/py3-elasticsearch/APKBUILD b/testing/py3-elasticsearch/APKBUILD
index 873c6f3a63..d9178f3819 100644
--- a/testing/py3-elasticsearch/APKBUILD
+++ b/testing/py3-elasticsearch/APKBUILD
@@ -1,56 +1,32 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=py-elasticsearch
+pkgname=py3-elasticsearch
_pkgname=elasticsearch-py
pkgver=5.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Official Python low-level client for Elasticsearch"
url="https://elasticsearch-py.readthedocs.io/"
arch="noarch"
license="Apache-2.0"
-depends="py-urllib3"
-#checkdepends="py-requests py-nose py-coverage py-mock py-yaml py-nosexcover"
-checkdepends="py-requests py-nose py-coverage py-mock py-yaml" # add nosexcover next release
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3 py3-urllib3"
+checkdepends="py3-requests py3-nose py3-coverage py3-mock py3-yaml py3-nosexcover"
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/elastic/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/"$_pkgname-$pkgver
+replaces="py-elasticsearch" # Backwards compatibility
+provides="py-elasticsearch=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
check() {
- cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
-sha512sums="9d30ffa810f495662769e6d2f2627f9ef6aa3849bc2eecd09df28c05a036b8fb15ae465914c38eeb3d854683bc150a3c56425388312bcd112bd5cc7b33ad41ae py-elasticsearch-5.4.0.tar.gz"
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9d30ffa810f495662769e6d2f2627f9ef6aa3849bc2eecd09df28c05a036b8fb15ae465914c38eeb3d854683bc150a3c56425388312bcd112bd5cc7b33ad41ae py3-elasticsearch-5.4.0.tar.gz"