aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-30 03:05:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-30 03:11:27 -0300
commit7627256f0bb8cdbf47e748739c8b5aea92f65e81 (patch)
tree76d4778eaa7665523ed5644ae93235512826e0ea
parentd8fc97d9db0b7108a9f787301be3c036d579b7d1 (diff)
downloadaports-7627256f0bb8cdbf47e748739c8b5aea92f65e81.tar.bz2
aports-7627256f0bb8cdbf47e748739c8b5aea92f65e81.tar.xz
community/osinfo-db-tools: upgrade to 1.6.0
-rw-r--r--community/osinfo-db-tools/APKBUILD11
-rw-r--r--community/osinfo-db-tools/fix-tests.patch27
2 files changed, 4 insertions, 34 deletions
diff --git a/community/osinfo-db-tools/APKBUILD b/community/osinfo-db-tools/APKBUILD
index fada74ec2b..0dc87dae66 100644
--- a/community/osinfo-db-tools/APKBUILD
+++ b/community/osinfo-db-tools/APKBUILD
@@ -1,19 +1,17 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=osinfo-db-tools
-pkgver=1.5.0
+pkgver=1.6.0
pkgrel=0
pkgdesc="Tools for managing the osinfo database"
url="https://libosinfo.org/"
arch="all"
license="GPL-2.0-or-later"
makedepends="intltool glib-dev libxml2-dev libarchive-dev libxslt-dev json-glib-dev
- automake autoconf libtool"
+ automake autoconf libtool libsoup-dev xz"
checkdepends="py3-pytest py3-requests"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://releases.pagure.org/libosinfo/osinfo-db-tools-$pkgver.tar.gz
- fix-tests.patch
- "
+source="https://releases.pagure.org/libosinfo/osinfo-db-tools-$pkgver.tar.gz"
prepare() {
default_prepare
@@ -39,5 +37,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="baa42086ae13365e463064f0313228ec79d785a863b72c396d2a24d35496420d17ea09191629663c8c67ec46f3168f256ff50896053244cd0255be6ac08583d1 osinfo-db-tools-1.5.0.tar.gz
-f1f4bd99a02f42b62e7f927f13a4ae5b5b3ff9e85add175bb753c064450cb52afb5eaa4cb4c709b6fdb203f6f00b87ffa8aadc19b3838cadcb6419c142a74dec fix-tests.patch"
+sha512sums="a3bdf9d913b388b0f567a14245f57c4f1da9dae40d723f8e76096ffdae9d7a8e587ed4832e3e59c820bc01bbb2b74815b3fefd8e1f47cebd903091457fdee951 osinfo-db-tools-1.6.0.tar.gz"
diff --git a/community/osinfo-db-tools/fix-tests.patch b/community/osinfo-db-tools/fix-tests.patch
deleted file mode 100644
index a727e6e497..0000000000
--- a/community/osinfo-db-tools/fix-tests.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Similarly to what's been done as part of 1df4c0dbede91, let's just unset
-XDG_CONFIG_HOME environment variable in our tests, in case those were
-externally set for some reason.
-
-https://gitlab.com/libosinfo/osinfo-db-tools/issues/3
-
-Signed-off-by: Fabiano FidĂȘncio <fidencio redhat com>
----
- tests/test_osinfo_db_path.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/tests/test_osinfo_db_path.py b/tests/test_osinfo_db_path.py
-index d813c34..b0b6aff 100755
---- a/tests/test_osinfo_db_path.py
-+++ b/tests/test_osinfo_db_path.py
-@@ -44,6 +44,8 @@ def test_osinfo_db_path_user():
- """
- if "OSINFO_USER_DIR" in os.environ:
- del os.environ["OSINFO_USER_DIR"]
-+ if "XDG_CONFIG_HOME" in os.environ:
-+ del os.environ["XDG_CONFIG_HOME"]
- cmd = [util.Tools.db_path, util.ToolsArgs.USER]
- output = util.get_output(cmd)
- expected_output = os.path.join(os.environ["HOME"], ".config",
---
-2.21.0
-