aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-18 17:48:46 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-18 17:48:46 -0300
commit797126ff380e453834691062957f8f1bfad548ff (patch)
treeb4c68b28c8885c15427941c98e9acb281d9c0f85
parent87f1d11ebc77f1abc587cdfcd7c9399c27fc27f4 (diff)
downloadaports-797126ff380e453834691062957f8f1bfad548ff.tar.bz2
aports-797126ff380e453834691062957f8f1bfad548ff.tar.xz
testing/efitools: upgrade to 1.9.2
-rw-r--r--testing/efitools/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/testing/efitools/APKBUILD b/testing/efitools/APKBUILD
index a00cb1e25f..7c0841d90a 100644
--- a/testing/efitools/APKBUILD
+++ b/testing/efitools/APKBUILD
@@ -1,34 +1,34 @@
# Contributor: Tero Hilpinen <tero.hilpinen@symbio.com>
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
-
pkgname=efitools
-pkgver=1.8.1
+pkgver=1.9.2
pkgrel=0
pkgdesc="EFI tools"
url="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git"
arch="x86_64"
-license="GPL"
-depends=""
-makedepends="autoconf automake binutils-dev gnu-efi-dev openssl-dev perl-file-slurp help2man sbsigntool"
-install=""
+license="GPL-2.0-only and LGPL-2.1-or-later"
+makedepends="gnu-efi-dev openssl-dev perl-file-slurp help2man sbsigntool"
subpackages="$pkgname-doc"
-source="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/$pkgname.git/snapshot/$pkgname-$pkgver.tar.gz
+source="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git/snapshot/efitools-$pkgver.tar.gz
001-datatypes.patch
002-fix-parallel-make.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ sed -i "s/-O2/${CFLAGS} -Wno-pointer-sign -O2/" Make.rules
+}
build() {
- cd "$builddir"
+ export ARCH="$CARCH"
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="114ef8e52160f5a5239ec306dbd587610849bce771ba8145ed092afd79e44f3ecee93cc1d97e2d5fdb880cc825bbbe928b3ef6701fd3b1fa444053894be1098a efitools-1.8.1.tar.gz
+sha512sums="77e0ad7e865814ed388ff6daabe0f4b49ba51672bf2cbb98b7905e209cbd28f9ede2f73213ce45af8a978c1e67dba24ec88a1188661317cc22317b47e575cde8 efitools-1.9.2.tar.gz
cd72161a99b26472909a8da834c08a1f88b54d35291a6646562b03a6616fa5fb61e49d4fb3c780861689d23823c101709890dd245dd8aa9f51dca40ac1b2d369 001-datatypes.patch
7afe87e9b44ed3e10200770d3079e4e14b6d39c54c05538031e93d021631427fed47781b016b46f58b8fe6d21f1f3c78667b2b502aa20b99516aa980303aa2ad 002-fix-parallel-make.patch"