aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-06-30 17:20:10 -0300
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-30 22:05:52 +0000
commit7b15e5e02e1e0600da4a59bab8cab50f50038d73 (patch)
treead5f858ae09a52a5ea5c3a79d44dff54c70ea73c
parenta6c2b315f6a4f0d8ac9e91ad4305dd686370ab45 (diff)
downloadaports-7b15e5e02e1e0600da4a59bab8cab50f50038d73.tar.bz2
aports-7b15e5e02e1e0600da4a59bab8cab50f50038d73.tar.xz
community/R: upgrade to 3.4.1
-rw-r--r--community/R/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index beb5698607..129769162d 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=R
-pkgver=3.3.3
-pkgrel=1
+pkgver=3.4.1
+pkgrel=0
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org"
arch="all !s390x"
@@ -50,10 +50,9 @@ build() {
--with-libpng \
--with-libtiff \
--with-tcltk \
- --with-x \
- || return 1
+ --with-x
- make || return 1
+ make
make -C src/nmath/standalone
}
@@ -62,11 +61,11 @@ package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# Install libRmath.so.
cd src/nmath/standalone
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
cd -
# Fixup R wrapper script (taken from Arch).
@@ -81,9 +80,9 @@ package() {
# R apparently ignores --sysconfdir, so we must manually move configs
# to /etc/R and make symlinks.
- cd "$destdir"/etc || return 1
+ cd "$destdir"/etc
local f; for f in *; do
- mv "$f" "$pkgdir"/etc/R/ && ln -sf /etc/R/$f $f || return 1
+ mv "$f" "$pkgdir"/etc/R/ && ln -sf /etc/R/$f $f
done
cd -
}
@@ -95,4 +94,4 @@ mathlib() {
mv "$pkgdir"/usr/lib/libRmath.so* "$subpkgdir"/usr/lib
}
-sha512sums="bcb0d92fc0b22c13e345a2f660e3b3cc5810f6a07c8f2e37949c81308c2b8a5edc322df0394ece563888645442b6c01a3e1e7005aa60bd9beacc718200829e75 R-3.3.3.tar.gz"
+sha512sums="19bd50c87dc001ef947c15c1760f27ac8986ff6b43c6d90d3093ae184e42963027ef06faf31ec57ac9e519af7a35a2f53f8ea23ef75d800ebbd02945cedc4651 R-3.4.1.tar.gz"