aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-04 08:11:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-04 08:13:08 +0000
commit7cde0706f4d64fe1c31b3ac055062bd5ecedbb18 (patch)
treefa6127143b7111524768d7638e58fc23cc1f7bc0
parent57573ef53763b904974e359a3d4a6d4b32215ce8 (diff)
downloadaports-7cde0706f4d64fe1c31b3ac055062bd5ecedbb18.tar.bz2
aports-7cde0706f4d64fe1c31b3ac055062bd5ecedbb18.tar.xz
main/pixman: fix build on arm
For more details see: https://bugs.freedesktop.org/show_bug.cgi?id=55519
-rw-r--r--main/pixman/APKBUILD21
-rw-r--r--main/pixman/float-header-fix.patch16
2 files changed, 32 insertions, 5 deletions
diff --git a/main/pixman/APKBUILD b/main/pixman/APKBUILD
index 30a62907b7..524d0d3154 100644
--- a/main/pixman/APKBUILD
+++ b/main/pixman/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pixman
pkgver=0.32.6
-pkgrel=0
+pkgrel=1
pkgdesc="Pixman library"
url="http://xorg.freedesktop.org"
arch="all"
@@ -9,13 +9,20 @@ license="custom"
subpackages="$pkgname-dev"
depends=
makedepends="perl"
-source="http://xorg.freedesktop.org/releases/individual/lib/$pkgname-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org/releases/individual/lib/$pkgname-$pkgver.tar.bz2
+ float-header-fix.patch
+ "
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -25,6 +32,7 @@ build() {
--host=$CHOST \
--prefix=/usr \
--disable-static \
+ --disable-arm-iwmmxt \
|| return 1
make || return 1
}
@@ -34,6 +42,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la || return 1
}
-md5sums="8a9e8f14743a39cf303803f369c1f344 pixman-0.32.6.tar.bz2"
-sha256sums="201fc0d7d6bc0017496f2bd27b3ca14224aea0df6b624c5ee2dc0307a4ff14a4 pixman-0.32.6.tar.bz2"
-sha512sums="162e34a3ac728b348b8cd429172fa9f6ba1fc8d94716368c84a8081c42c4e2639ec7624e5528d9059695736be785ee210835c7d832b4a07a2175aec349ddffe9 pixman-0.32.6.tar.bz2"
+md5sums="8a9e8f14743a39cf303803f369c1f344 pixman-0.32.6.tar.bz2
+c13c42fe7459ae8f1eced7db4fb918b2 float-header-fix.patch"
+sha256sums="201fc0d7d6bc0017496f2bd27b3ca14224aea0df6b624c5ee2dc0307a4ff14a4 pixman-0.32.6.tar.bz2
+0ae5d4e8d875c175d7b232d61e2ef1b8ae17d08fd2538cb60844b94de701bcf5 float-header-fix.patch"
+sha512sums="162e34a3ac728b348b8cd429172fa9f6ba1fc8d94716368c84a8081c42c4e2639ec7624e5528d9059695736be785ee210835c7d832b4a07a2175aec349ddffe9 pixman-0.32.6.tar.bz2
+5064da221fe406e58169df0b07df7123ccf65487e654dba9e0903122480363c2b4e11ec0a14ac546658c747934509f2f66e3d0d078d6dd0ac92505c24b0e9ee9 float-header-fix.patch"
diff --git a/main/pixman/float-header-fix.patch b/main/pixman/float-header-fix.patch
new file mode 100644
index 0000000000..5c151a14f6
--- /dev/null
+++ b/main/pixman/float-header-fix.patch
@@ -0,0 +1,16 @@
+--- ./pixman/pixman-private.h.orig
++++ ./pixman/pixman-private.h
+@@ -1,5 +1,3 @@
+-#include <float.h>
+-
+ #ifndef PIXMAN_PRIVATE_H
+ #define PIXMAN_PRIVATE_H
+
+@@ -30,6 +28,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stddef.h>
++#include <float.h>
+
+ #include "pixman-compiler.h"
+