aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-11-03 23:22:04 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-11-03 18:33:34 -0300
commit7ffb9c86bb3d9779b75b0813bcecfce0e5b7eabe (patch)
tree05ab382ccfe53b66d56162eef6116ec89d37d5fc
parent34b781e0c29bc98f206a170d6e2ac3fb707975e4 (diff)
downloadaports-7ffb9c86bb3d9779b75b0813bcecfce0e5b7eabe.tar.bz2
aports-7ffb9c86bb3d9779b75b0813bcecfce0e5b7eabe.tar.xz
testing/ponyc: upgrade to 0.33.0
Add static subpackage and rework failing march/mtune patch. New version defaults to statically linking against llvm-libs. Use `link=llvm-dynamic` to revert.
-rw-r--r--testing/ponyc/APKBUILD12
-rw-r--r--testing/ponyc/makefile-remove-march-mtune.patch8
2 files changed, 11 insertions, 9 deletions
diff --git a/testing/ponyc/APKBUILD b/testing/ponyc/APKBUILD
index 6d74387db9..3ea43809d9 100644
--- a/testing/ponyc/APKBUILD
+++ b/testing/ponyc/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=ponyc
-pkgver=0.32.0
+pkgver=0.33.0
pkgrel=0
pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
url="https://www.ponylang.org"
@@ -15,8 +15,8 @@ checkdepends="openssl-dev pcre2-dev"
makedepends="libexecinfo-dev llvm$_llvmver-dev ncurses-dev paxmark
zlib-dev linux-headers"
options="!check"
-subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/ponyc/archive/$pkgver.tar.gz
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+source="ponyc-$pkgver.tar.gz::https://github.com/ponylang/ponyc/archive/$pkgver.tar.gz
more-portable-ln.patch
makefile-remove-march-mtune.patch"
@@ -28,6 +28,7 @@ build() {
make \
config=release \
default_pic=true \
+ link=llvm-dynamic \
verbose=true
paxmark m build/release/ponyc \
@@ -45,6 +46,7 @@ package() {
make \
config=release \
default_pic=true \
+ link=llvm-dynamic \
ponydir="$pkgdir"/usr/lib/pony/$pkgver \
prefix="$pkgdir"/usr \
install
@@ -71,6 +73,6 @@ dev() {
mv "$pkgdir"/usr/lib/pony/$pkgver/include "$subpkgdir"/usr
}
-sha512sums="16fb61d952017e9c40dd2683fd7ca78b2da1cabbf813f16374b8ab080e28c8c0cd8fd284b9eacd8e05e828dbf1ab647d4d1970be5c7aafd8d2a7e8162e768bf0 ponyc-0.32.0.tar.gz
+sha512sums="bc867af4334ca4aff5c4eefad9ac5ee3ea6027a4f021c5af4ae144a310f14c99207878ca24017face7c543bb7b4f8ee801c49d9368f5a3e6e7763abc5f867a6a ponyc-0.33.0.tar.gz
38aa40f6000dcb823be7b542cdad8d04b6ac4cd0a4fff1a472520a7cb71631fb34e5bee74914fe559674594dd901aede91390809e143dd96c5d68a16f8ac196c more-portable-ln.patch
-c78156bc68332705c41e7f4f8ff65bb77a778d8ee1685e9376473041c9c0b815e96ebc4cfd68b03c5c5c9d53cff8e6c0deba0fc19a9bcb29b7f91caaa15a0803 makefile-remove-march-mtune.patch"
+ce98aa2e33d057714703364509afd15e42ba53b5fefd42b66b9996a69036767595b868ddda592695bb109f09a7e1de118a53f262c2b23cbdf0b84063245f8b1b makefile-remove-march-mtune.patch"
diff --git a/testing/ponyc/makefile-remove-march-mtune.patch b/testing/ponyc/makefile-remove-march-mtune.patch
index 3bee239b16..2b81fb00a4 100644
--- a/testing/ponyc/makefile-remove-march-mtune.patch
+++ b/testing/ponyc/makefile-remove-march-mtune.patch
@@ -25,7 +25,7 @@ index 50f4936..8f28e1a 100644
# Determine pointer size in bits.
BITS := $(bits)
-@@ -135,11 +135,6 @@ ifeq ($(BITS),64)
+@@ -147,11 +147,6 @@
endif
endif
@@ -34,6 +34,6 @@ index 50f4936..8f28e1a 100644
- LINKER_FLAGS += -mfpu=$(fpu)
-endif
-
- PONY_BUILD_DIR ?= build/$(config)
- PONY_SOURCE_DIR ?= src
- PONY_TEST_DIR ?= test
+ ifdef link
+ ifeq (,$(filter $(link),static llvm-static llvm-dynamic))
+ $(error Unknown linking strategy "$(link)")