aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-30 22:38:27 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-30 22:39:06 +0100
commit8097e8c095a5fdd1a14d772bb70c4b490fb6d32c (patch)
treef44c753d58d41fb5aea5316aaf76eac60dca5041
parent63f5e7d295659a855709901ce22a3e5f40fce455 (diff)
downloadaports-8097e8c095a5fdd1a14d772bb70c4b490fb6d32c.tar.bz2
aports-8097e8c095a5fdd1a14d772bb70c4b490fb6d32c.tar.xz
testing/python3.4: delete aport
-rw-r--r--testing/python3.4/APKBUILD88
1 files changed, 0 insertions, 88 deletions
diff --git a/testing/python3.4/APKBUILD b/testing/python3.4/APKBUILD
deleted file mode 100644
index 000c0ac431..0000000000
--- a/testing/python3.4/APKBUILD
+++ /dev/null
@@ -1,88 +0,0 @@
-# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-_basever=3.4
-pkgname=python$_basever
-pkgver=$_basever.5
-pkgrel=3
-pkgdesc="A high-level scripting language"
-url="http://www.python.org"
-arch="all"
-license="custom"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-tests"
-depends=""
-makedepends="expat-dev libressl-dev zlib-dev ncurses-dev bzip2-dev xz-dev
- sqlite-dev libffi-dev tcl-dev linux-headers gdbm-dev readline-dev"
-source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz"
-builddir="$srcdir/Python-$pkgver"
-
-prepare() {
- default_prepare || return 1
-
- cd "$builddir"
- # force system libs
- rm -r Modules/expat \
- Modules/zlib \
- Modules/_ctypes/darwin* \
- Modules/_ctypes/libffi*
-}
-
-build() {
- cd "$builddir"
-
- ./configure \
- --prefix=/usr \
- --disable-rpath \
- --enable-ipv6 \
- --enable-loadable-sqlite-extensions \
- --enable-shared \
- --with-computed-gotos \
- --with-dbmliborder=gdbm:ndbm \
- --with-system-expat \
- --with-system-ffi \
- --with-threads \
- || return 1
-
- make EXTRA_CFLAGS="$CFLAGS" || return 1
-}
-
-package() {
- cd "$builddir"
-
- make -j1 DESTDIR="$pkgdir" EXTRA_CFLAGS="$CFLAGS" install maninstall \
- || return 1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
-
- ln -sf ../../libpython${_basever}m.so \
- "${pkgdir}/usr/lib/python${_basever}/config-${_basever}m/libpython${_basever}m.so" \
- || return 1
-
- # Remove symlinks without _basever to avoid conflict with python3 package.
- find "$pkgdir"/usr/bin ! -name "*$_basever*" -delete
-}
-
-dev() {
- default_dev || return 1
-
- # pyconfig.h is needed runtime so we move it back
- mkdir -p "$pkgdir"/usr/include/python${_basever}m
- mv "$subpkgdir"/usr/include/python${_basever}m/pyconfig.h \
- "$pkgdir"/usr/include/python${_basever}m/
-}
-
-tests() {
- pkgdesc="The test modules from the main python package"
- arch="noarch"
-
- cd "$pkgdir"/usr/lib/python$_basever
- local i; for i in */test */tests; do
- mkdir -p "$subpkgdir"/usr/lib/python$_basever/"$i"
- mv "$i"/* "$subpkgdir"/usr/lib/python$_basever/"$i" || return 1
- rm -rf "$i"
- done
- mv "$pkgdir"/usr/lib/python$_basever/test \
- "$subpkgdir"/usr/lib/python$_basever/
-}
-
-md5sums="5caaca47eead170070a856fae5f6e78c Python-3.4.5.tar.xz"
-sha256sums="ee64b1c8a47461009abf25252332d29a4e587cb4f0c1c96aa793a3732e9d898a Python-3.4.5.tar.xz"
-sha512sums="b548a5338d141b3086dea372fa2cc245ba5350ee9f0d1304ef6222dc45380b66d380b092e547d54206d56ca68563b95036f445f97f72bb0ef1d48f81a74a3d4c Python-3.4.5.tar.xz"